Paewang Revolution PCB won't work on some Xbox360s


#1

Hello people. I biult an arcade stick some time ago using a Paewang and it stopped working on some Xbox360s. But if works normally in Xbox360 mode on PC.

Any ideas on why is this happening? I found [this thread]([HELP] Joytron Paewang Revolution PCB resistor replacement but I’m not sure is the same case.

Thanks.


#2

So its working on the PC but not a actual Xbox 360 at all?
The Encryption/Authentication chip could be dying/dead.


#3

You could always try replacing the USB cable before you start to panic.


#4

I don’t really think the cable is the problem because if thats the problem it should fail on PS3 and PC too…

I was fearing that. Oh man.


#5

Not necessarily. From personal experience I’ve handled cables that have been damaged in such a way that it makes it hard for certain systems to detect while appearing fine on others. A fresh, good quality USB cable fixed this.


#6

I follow Gahrling recommendation if nothing else then its a easy, cheap fix.
The stock USB cord for the Paewang isn’t that well made anyways.

When trouble shooting you always want to go in order from the most easy and simple, and cheap Fixes first and work your way down to harder, more complex repairs/causes.

Like on your car, got engine trouble. Check the oil first, if the engine oil level low, fill the oil up. If the issue gone then it was just the oil level.
If their a puddle under your car afterwards, then your oil is leaking. If you do not have issues with the oil, check the mileage you might be due for a oil change or a tune up.
And you work your way from there.


#7

I totally second this statement. I’ve tried to cut down the stock USB cord to the Paewang into shorter internal PCB --> USB-A (on a Neutrik) cables. They never worked properly and were always super-loose on the Neutrik USB-A side of things.

@RenzokuFC‌
You say “stopped working on some Xbox360s”. Were you able to keep track of which ones it worked on and which ones it didn’t? ie: older vs newer models, or very used USB port vs seldomly used USB port, etc.


#8

IIRC I changed the cable in that PCB, but It wont hurt changing the cable. At least is cheaper than expending $60 on a PS360.

@FreedomGundam‌ : It’s really random. I thought the problem only happened with slim models, but also got trouble with older ones.

Thanks for the advice guys, I’ll try changing the cable.