PC and HDTV slow motion and lag


#1

Does anyone else get lag and slow motion when connecting a PC to an HDTV playing SFV? I have a custom built gaming PC with a 780 GTX, 16 GB RAM, quad core CPU, ssd. My HDTV is a Vizio M series which has best in class display lag for 2015. I had some friends over to play SFV and since I don’t have a PS4, I had to lug my computer to the living room to play but was surprised by the amount of lag. I did the basic setup like connecting the GTX 780 using HDMI to the proper port on the TV and ensuring it was in game mode. I tried many different resolutions. The only resolution that was playable was a 720p mode but it looked terrible but at least it was lag free. Has anyone experienced this and have any tips?


#2

Tips. Match the resolution of your Display with your source.
If your Display is 720p set your PC to out put 720p.
If it’s 1080p set your Display to 1080p.

If your HTVD has a PC mode or a Game mode turn that on to bypass any extra post processing.


#3

Sounds like your PC can’t handle 1080p and that this isn’t a display lag issue at all. Does it run well on a monitor at that resolution?


#4

That true, you have to make sure where your lag is coming from.


#5

I run SFV fine on the same/higher resolution than that with a lower specced machine (2500k/GTX 670) with everything on max settings, so unless there’s something seriously wrong with your setup your system should really be fine.

Make sure you’re in true fullscreen and not windowed fullscreen. You could also try disabling vsync in the game config and then forcing it on for the application with Nvidia (or disabling it entirely if you want less input lag or don’t experience/care about screen tearing). You could also try a reinstall of the game.


#6

Also keep in mind the Street Fighter V game it self lags more than Street Fighter IV


#7

The game runs fine on my 1080p Asus monitor, no hiccups. My HDTV is 4k native, 2160p. I believe that is native. I’ll try that. TV is in game mode.

That’s great to hear your experience. Sounds like it is some type of setup issue. SFV runs great and no slowdown, lag or anything at 1080p on my monitor using dvb connection.

I connected HDMI to HDTV, went to geforce experience to optimal settings and it was unplayable. I’ll make sure it is true full screen, I thought it was. I didn’t see vsync setting, that could be the issue.


#8

Make sure that you are playing at 60hz. If it’s at 30Hz it will be in slow motion. I had this problem last night and figured that out.


#9

I have this same issue with my laptop. Game runs fine when playing normally, but when hooking to an external display it will start to stutter at random times. I genuinely feel it’s just something really poorly coded with SF5, i mean let’s face it, the game is kind of a mess.


#10

I know I tested it again and taking all suggestions and couldn’t get it to run right. My system is certainly powerful enough. Is anyone at all running the PC version of SFV and playing through an HDTV? Is it running OK?


#11

In the game try reducing the Resolution Scaling to like 70% or even 60%.


#12

Try Enabling borderless window mode. It worked for me With Fallout 4 to keep the game from Crashing.


#13

i have this same problem when i run fightcade through my laptop to tv


#14

That was it! For some reason the display was set up at 30 Hz in Windows 10 properties. Set it to 60 and it’s great!