PC: SSF4AE Region Issue Solution Here!


#1

Hello Shoryuken community,

A few others beside myself are having problems with their region settings in Super Street Fighter 4 Arcade Edition.

NOTE: This problem only tends to be on Windows Vista/7 systems due to their similar operating ways.

Example:
I am from The Netherlands (West Europe), But whenever I logged in, It would’ve been set to United States which gave poor connection when I tried searching for matches.

After 5 long days of calling support lines and emailing back and forth.
Checking multiple services;

  • Email. (Windows Live ID)
    It was already set to The Netherlands
  • Steam Account (Purchased it through steam)
    It was already set to The Netherlands
  • Xbox Live Support
    They confirmed my account was Dutch aswell.

After talking to them a bit more I have found the solution to this problem and I am hereby presenting it to anyone who is still dealing with it, so they can fix this aswell.

Unlike other games, SSF4AE doesn’t use the Xbox/GFWL account settings but the computer settings itself.
Why? you ask.
… No bloody clue.

Here is what you need to do:

[Depending on the language of your computer, the names of things you have to click may vary, please translate the english words into your own language]

  • Start
  • Control Panel
  • Region and Language (You can also try searching ‘Region’ in the top right search bar
  • Go to the ‘Location’ Tab
  • Set ‘Current Location’ to where ever you live, My case; Netherlands. (This was set to United States)
  • Go to the ‘Format’ Tab
  • Set ‘Format’ to where ever you live, My case; Dutch (Netherlands). (This was set to United States)
  • Look through your ‘Date and time formats’ to see if everything is set correctly.
  • Press ‘Apply’ and then ‘OK’
  • Launch the game.
  • Login
  • Your region is now set correctly.

Leave a comment below to tell me if this worked or not.
If not, please state your computer specifications and other information that is relevant.

Big thanks to ‘Jeroen’ at Xbox Live Support for helping me figuring this out.

Regards;
Shinymarble


#2

Thank u VERY Much.I am 4m india,it was set to US,Changed it.Thanks again.


#3

I could see how this would help someone so I voted you up. My windows is already set, they ask you this when you install. Game still runs like ass online.


#4

Glad I could help hailahaiela,
Let’s try and bring this post to the attention of those who need it.

[OFFTOPIC] The game is fine online… if both internet connections are good. [/OFFTOPIC]


#5

Actually we can hav good matches if both players r from same region,everytime.So everybody should correct their flag if not set accordingly…thus we can find easy playable matches online.


#6

Stellar, that helped me also. Mine was set to US as well.


#7

Glad I could help.
I know how annoying it can be.
If you know anyone with this problem.
Redirect them to this thread. :wink:


#8

The format doesn’t matter, just your location setting will do.


#9

I know,
But now that the person is busy setting it’s location correct, why not do it all the way. :wink:
Thanks for your concern.


#10

Works just as well on windows XP. Thank you.