PCB stop working HELP!


#1

OK, i got a dual modded PCB that does 360/PS3, also has a PS2 cable to work on PS2. I let someone borrow my stick & when they brought it back they said it stop working.

They were playing on a PC playing GGPO & when they fired it up the next morning it stop working. But the PS2 still works, any idea what happen?

There is scent of something burning when i opened it up like battery leak if that helps…

What do you guys think is wrong/cause?


#2

Some kind of short. Might have let the magical smoke out.


#3

Is there way to fix it or is it fried? Is there a way to see which is working still? Cthulu/imp/360, i mean if the PS2 is still working, that would mean the Cthulu would be working right? But why will it not work for the PS3?


#4

There are ways to tell if it’s fried. I think the next step is probably ‘picture of the guts’, since I can’t help you until I know how the inside of the stick is set up.


#5

Somethings most likely shorting out. PS3 should work too. Otherwise, maybe the cable for the PS3 USB has an issue.


#6

Here some pics hope you can help…

Let me know if you need closer shot of particular part…


#7

Does the 360 pcb side work? i’m leaning toward you having a bad USB cord. All the soldering seems to be clean from the pics


#8

what is that brown shit on your ribbon cable. you say something smelled like it was burnt that stuff looks pretty corrosive in the pic.


#9

360 & PS3 does not work, PS2 works fine…

Yeah not sure what that brown stuff is but yeah looks like messed up but how come the PS2 is working then?


#10

it’s your USB cable most likely. if you have no one else to troubleshoot and repair, then we can do it at J&J for a fee…

the brown stuff is the old crusty glue i believe. if you have a breakaway cable, try replacing that first, then try replacing the whole USB cable. if your ps2 works on that cthulhu, but 360 and ps3 are not, then there should only be the USB issue left


#11

Yeah, i tried different breakaway cables, so do i just cut of the whole cable & then just rewire a new one? Can it be any usb cable or does it have to be a 360?


#12

I wonder if the eletrolytic capacitor there popped for some reason. Does the top of it (cylindrical black object) still look like a solid piece of metal - also does that area smell more than other areas?

Any USB cable will work.


#13

All the cylindrical black seem fine…That brown junk stuff is the headset part, there’s also some brown burnt stuff next to the switch im guessing that does analog or the turbo switch…

Actually i tried smelling it & seem all the same, dont really notice it as much…The cable smells burnt though…

i guess ill try replacing the cable tonight…


#14

oki replace the cable & the PS3 is working fine again…Thanks guys!

So im trying to get the 360 to work but for some reason its not recognizing it…I remember having to hold down select or start or both for like 5 seconds before plugging it in, dont remember…Is it possible the 360 PCB was the reason the wire got damaged?