Please Try This Street Fighter x Tekken PC Online Teleporting Solution, Guys!


#1

As Capcom stated, the SFxTK PC online teleporting is happened because PC has different hardware specs each other which result different framerate on gameplay. This will make problem when synchronizing rollback frame on online gameplay. Unlike console which have exactly same hardware specs.

You can check framerate on benchmark game. If it show some crazy 90 - 200 fps based on your PC specs then we must fix it. We can make the framerate constant on 60 fps. How do we do that?

Step 1: Turn on Vsync.

Step 2: Turn on Triple Buffering. But how do we do that?

  • For Nvidia cards: go to Nvidia Control Center -> 3D Setting
  • For ATI cards: download and install Rivatuner and then start D3doverrider app

Make sure vsync is turned on too.

Now we can go back to benchmark game and see its result. Now it show on constant 60 fps.
Try to play online with somebody with this constant 60 fps setting too and see the result! I hope it will help everyone. :slight_smile:

This solution is worked on SSF4 AE too.


#2

I never had this problem in SSFIV AE. I’m thinking it’s the same with many PC players.

But anyway… since I’m messing with my video cards would it also affect all other games I play? I’m illiterate when it comes to comeputer tech terms, what does triple buffering do?


#3

this shouldn’t affect gameplay since the netcode is independent from the rendering cycle.

tp only makes sense with vsync on. to put it in a nutshell: it prevents the gpu from waiting for the next display sync and doing nothing. this reduces or eliminates fps drops.


#4

Triple buffering is used for eliminating input lag because of vsync too.


#5

Is there no fixed framerate setting in the options menu like it was in SSF4AE?


#6

I’m fed up of even trying anything to be honest. The fact I even have to try to fix anything like this just gives me enough reason to not even bother with the game anymore.


#7

that’s acually just a side effect.

you can set it to fixed in the config file. but there is no noticeable difference.


#8

If your PC doesn’t suck, rendering is fixed to 60fps during gameplay … it should only vary during the benchmark. Adding vsync might help a tiny bit, but it’s going to add input lag (and triple buffering is only going to add more input lag).


#9

that’s incorrect. there are some games where the developers inlclude a triple buffering option which is actually a render ahead queue. but that’s not tp. tp just forces the gpu to render new frames while waiting for the next display sinc. at this point the newest frame rendered while the gpu was waiting will be send to the display. so there is absolutely no input lag in comparision to vsync off, since there is no frame stack which must be displayed in contrast to the render ahead queue.
to make sure that you have proper tp and not a render ahead queue you should enforce tp and vsync with d3doverrider and disable the flip queue (ATI) or the render ahead limit (Nvidia).

triple bufferung and vsync in more detail if someone is interested:
http://www.anandtech.com/show/2794/1


#10

I’ve tried this is so far it dropped my benchmark to B. I think this will only work on computers which exceeds the game’s recommended system requirements. My rig is just enough to put the benchmark in A and any improvements from the default setting will slow my game’s framerate.