Possible PS360+ PCB problem


#1

I’ve searched the forums and I haven’t found an answer to my problem, although I’ve found threads with similar issues. If something has already been posted, please direct me there.

After 2 months of use, my dual modded stick with a PS360+ starting to act up. The joystick would stop responding in the middle of matches. After further inspection, I thought the ground on my harness was loose so I decided to buy a replacement.

I installed the new harness and everything was great for the first 3 hours or so. Then the stick went completely unresponsive–neither joystick nor buttons were working. I unplugged the stick and plugged it back in to get it working again, although the LED stayed on and I never got a please reconnect controller message. After about 20 mins of play, same thing happened again.

One time I was able to fix it by just moving the cable, but that only worked once. It also seems to happen in between matches or when I return to the main menu. Also, sometimes it’s just the joystick that doesn’t respond while the buttons are fine.

I am going to update the drivers today to see if that helps, but I’m afraid it’s a PCB issue.

Please help!


#2

Try replacing your USB cable… all of it.


#3

I just tested it out with a new usb cable and the joystick stopped responding after about 10 mins of play… I should mention that it stopped when I was mashing inputs. Mashing caused it to stop last night too.


#4

Are you pressing select while mashing? Sounds like you’re entering configuration mode.

Next time it stops responding try pressing up on the joystick and then start. See if it’s back to normal.


#5

This sounded spot on to me, so I went into training and tested out how my stick would respond to the different options in configuration mode. Low and behold, this was my problem the whole time.

I’m playing with a Hori VLX, so I basially lost my select and home buttons after installing the PS360+. I didn’t think it would be such a big deal, but after a few situations in tournaments came up where I could have used the home button to reassign controllers I decided to map the select button to my 3P.

I’ve been mashing all four punches during dizzies or sometimes in between matches and that is what has been throwing my stick. Now I’ve got to get serious about transitioning from an 8 button layout to 6!

Thanks for all of your help Phreakzoid and gahrling!!

Just to elaborate configuration mode for any future readers… when I pressed select+lp+mp+hp I entered configuration mode. While in configuration mode, none of my buttons responded (except for start). In configuration mode, I sometimes assigned the stick to right stick by accident, which is why I couldn’t move my character, but the buttons worked.