Problem: Dreamcast, or Games?


#1

Hi, I just bought “Sword of the Berserk” this weekend for my dreamcast, and didn’t try playing it until tonight. I put the game in, and it just brought me to the dreamcast menu screen. I thought that was kind of odd, but I went ahead and went to the “game” option on the screen, hoping that would start the disk. No luck. It waits a second, and then reboots back to the main menu. I restarted and tried again, same thing. I figured the game was messed up, but the disk looks great, so I didn’t understand. For the hell of it, I got out my old, one-controller-port-working, beat up dreamcast, and plugged in it. The game worked great. I couldn’t understand.

I took the game out, put it back in my good dreamcast, and still, got the same dreamcast menu as before. Confused, i got all my dreamcast games out and tried them on my good system, they all worked, except one…Tomb Raider: The Last Revelation. I got the same thing: the dreamcast menu, with the 4 options: (game, VMU, music, settings). Now I was really confused. I then tried last revelation in the bad dreamcast (that for some reason played ‘sword of the berserk’), and it didn’t work in that one, either. I just don’t understand. Does my system just hate games that are made by Eidos? Both games look pretty darn good, but they just bring me to the menu. What should I do? My good dreamcast works great, and I’ve never had any problems…


#2

Don’t know what’s going on there, they are legitimate game GD-Roms aren’t they?

Have you tried cleaning the discs and/or the DC laser? Maybe the laser in your good DC isn’t as strong as the one in your older DC which is why it’s having trouble reading the game disc. A clean may help.

Other than that, you could try swapping the laser assemblies over and see what happens, at least then you’ll know if it’s the laser or the unit itself.

Hope that helps a little :karate: