Problem with my MAS stick


#1

My Medium kick on my MAS stick is only working 6/10 times. I bought it off the Trading Outlet. I was wondering how would I fix it? It is the red button.

http://img.photobucket.com/albums/v602/imtony/Picture008-1.jpg

http://img.photobucket.com/albums/v602/imtony/Picture013.jpg


#2

Gotta love MAS and their solid copper ground wire.

I don’t see anything obvious in the picture you provided. Did you check the cherry microswitch to see that it’s clicking fine when you depress the button? Is there any interference with some of your electrical lines hitting other lines?

If the ground wire (the copper line) and the purple line both appear to be soldered correctly to the cherry microswitch, it’s hard to tell what else could be wrong. You’ll probably end up resoldering the connections whether you get a new cherry microswitch or you have faulty electrical connections.


#3

What system is this for? The PCB is awesome small.

This is a perfect example of why I wish people would use quick disconnects. Desolder the button and the ground wire from it (purple and gold). You can then try swapping in another button or microswitch if you have one available. You could also desolder another button and try swapping things around. It’s going to be a matter of trial and error. This also assumes there’s not a problem with the PCB or its wiring.

Good luck.

Also, if you aren’t comfortable with any of this I’d recommend asking someone in the Trading Outlet to get you a new PCB and use quick disconnects.