Problem with my new Sanwa joystick


#1

I kind of feel bad that my first post on SRK is asking for help, but I feel this is important.

Well, a couple days ago I installed a JLF-TP-8YT-SK and 6 Sanwa buttons into my SE. The buttons worked fine, but when I tried it out the up direction would not register. So I couldn’t do up, up/left, or up/right. After this happened, I opened up my SE again and connected my stock stick to the wiring harness. I still had the same problem, so it wasn’t the microswitches in the JLF.

Can someone please help me determine what the problem is (I feel like it’s the wiring harness but I’m not sure) and tell me how to fix it?


#2

Plugged in the Connector upside-down?


#3

wire loose/shorted at pcb area?


#4

When my Sanwa JLF wiring harness wires stopped working, I scrapped the wire harness and just soldered wires to microswitches instead.


#5

what would cause the wiring harness wires to stop working on a Sanwa JLF though? are u talking about a TE or a different stick?


#6

Maybe you should check what is the position of the switch near home button. It should be on D-pad.


#7

facepalmIt was just the wiring harness that was loose. All I had to do was wiggle the wiring harness around and push a little harder.