Problem with my new TE Fightstick


#1

Hey guys,

So I just got my hands on a TE stick and I’ve run into a bit of a wall.

So I plugged it in, everything was golden until about five minutes in and a message appears on the screen saying: “please reconnect controller.”

So I unplugged it and plugged it back in again, and nothing happened. I held in the Xbox button in trying to reconnect it and still nothing.

So at this point, I plug it into the Xbox, all of the Turbo buttons light up red and stay that way, and the Xbox ring button stays permanently green. So I figure it’s receiving power but for some reason its not connecting.

Has anyone else had this problem? How have you gone about resolving it?

Thanks in advance guys,
sam


#2

MIght be the break away i just took the one from my rock band guitar and its fine now.


#3

hey yankee,

whats a breakaway?


#4

Breakaway cord, sir. You know how on the end of your cord, how it has that detachable end, so say, someone trips and the breakaway cord pops off instead of it jacking up the port on your system, or yanking on the system and making it fall? That little dongle piece.


#5

Thnks sorry should have explained that better.


#6

Hey thanks for the feedback guys,

Hmm, alright. I’ll see where I can get one of these badboys.

Thanks bros,

Sam


#7

They’re all over Ebay for $5-$10 so you should have no trouble finding them.


#8

hey guys, i purchased 2 on ebay and neither of these fixed the problem, resulting in the same issue as the original breakaway cord. Any suggestions on what to do next?


#9

sounds like the pcb dude your gonna have to send it in for RMA (warranty repair)


#10

Why not try a few more things, like holding the turbo button in for about 8 seconds (this resets any current enabled turbo buttons)

Have you tried plugging it into your PC/MAC? and running some tests?

My TE had issues with the Turbo pcb and led’s, I went ahead and opened it up and found two weak solder points, re-soldered and all fine now.

It could be just a lose wire inside which would be easily fixed…


#11

Hey guys thanks for the replies,

ok, well I plugged it into the PC and it still has the same result as always.

I held in the turbo button for the 8 Seconds and still no response.

Do you think I should crack it open and see whats going on inside?

My cousin bought it for me in America and sent it over (I’m Australian) so should I try and send it back for warranty repair or would the shipping cost more than just cracking it open?

Thanks for the advice so far guys


#12

Sorry to hear about it dude. Shipping will be a bitch. I say get a cthulhu PCB (solderless) and mod it yourself.


#13

Mod it himself with a cthulhu??? What are you talking about. He’s using it for the xbox…

One of two things is happening. Either your usb cable wasn’t soldered on well (very possible) or your PCB is bad.

You aren’t gonna be able to really fix it without getting your hands dirty.


#14

This is exactly what happend to me on my TE stick. The solder was done bad and i redid it myself.