Problem with my newly acquired ls-56 (TE S)


#1

Hello,
I just moded my TE S with new buttons and a ls-56-01 (the deadzone of the jlf is too high for shmup imo).
But I have a problem :
The only direction that works is down, and downleft diagonal (left don’t work).
I reinitialized the driver, used the microsoft and the xbcd, but nothing works.
I plugged my old jlf to check if the pcb is ok and it works flawlessly.

Any idea? Or the ls-56-01 is simply dead on arrival?


#2

check the LS-56 pcb or the wire harness. the contacts for a JLF and LS-56 have different orientation depending on the position of the pcb


#3

Rotate your wiring harness 180 degrees. Seimitsu wiring harnesses are inverted versions of Sanwa harnesses. And the stock TE harness is designed for Sanwa sticks.


#4

You mean returning the cable?
I guess I’ll have to made a custom cable … Before that I’ll test the pcb tomorrow with an electrical tester.

edit: i’m a bit in wtf mode. returning the cable works, but it didn’t that afternoon… well, that’s good. :slight_smile:


#5

You have two ways of plugging the connector to the LS-56. Try the 2nd way (nerrage’s advice)


#6

This will help you make sense of how it was plugged in wrong.


#7

Yes it make sense. There is no electrical schema included with the stick itself tho. :confused: Even if the ground track is a bit more wide.
I still don’t know why it didn’t worked that afternoon (I tried both).

But the only thing that matter is that it works now. :wink: