Problem with pelican converter and dualshock 2


#1

So i haven’t used them since like september, but when i fired up my ps3 today with a dualshock 2 connected via a pelican converter it had problems detecting the left direction on the dpad. i tried 2 other dpads and had the same problem. i plugged in some ps2 joysticks and they all worked.

it wasn’t the game because it happens at the xmb too. i don’t know when i got firmware 2.10 but could that be a problem?

edit: the led on the converter doesn’t show what port the controller is assigned to either. all 4 lights continuously blink.


#2

Dunno this is a new one. Mine are working fine.


#3

i’m thinking my ps3 might be the cause somehow because it’s happening to both my pelicans.


#4

Try it on your PC and see how it works.


#5

I think the problem your having is that POS Pelican converter.:rolleyes:


#6

Wow.


#7

Seriously…


#8

get a radio shack converter. i have the same prob with my pelican. The pelican works fine on my t5 hori but not the dual shock.


#9

It’s your dualshocks, I have a brother who uses a DS2 on the Pelican all the time. We have two as well, and it works on both.


#10

i’ve have 3 dualshocks and they all have the same problem. i do remember using the pelican with ds2’s before.

the weirdest part of it is that when I plug it in the ps3, even with a stick, and press the button on it the none of the leds stop blinking. it’s supposed to light up only on the port the controller is assigned to.

will have to try try ds2 on it then i’ll try it on a different ps3.