Problem with Street Fighter Anniversary Stick


#1

I just recently got the stick from ebay, not modded, used, brought to me in great condition, but when i plugged it in no response, tried cleaning both the controller port and the port on the ps2,still no response, after serveral ideas(ill explain later shortly )

I thought maybe the wiring inside must be tampered with , checked wiring inside nothing out of the ordinary so at this point it was just WTF, so i emailed the seller and said he had tested it multiple times before he sent me it to me and said there were no problems whatsoever.I believe him cause cmon ebay sellers live off of ratings.

Anyways along the trouble shooting process, I finally decided to try using the controller with my old PS1(the first version not slim kind) a very dirty system, and what the hell, IT WORKS, so now I know that there is no internal problems but now im at a complete loss.How come it wont work for my PS2?! Heres what I have tried.

-Cleaning both controller ports on the system.
-inserting controller into port 1 and 2,
-using a multi tap and plugging the controller into every slot to see it it works that way.
-using a different game besides Street Fighter Anniversary Edition for Ps2
-Checked wires internally(recap from before)
-double checked to see if the controller was plugged in fully(not partially)
-Its worked on PS1 system, and worked for another’s PS2 systems both slim and fat.

So after all this its obviously my ps2 that’s the problem, I know that much, but can anyone give ideas why mine is acting this way?

Its a Slim ps2, its not modded, and I’ve owned it for about a year. No exterior damage whatsoever.


#2

That is a wierd problem, do you plug it into the controller port before it’s powered on or after it’s already powered up?


#3

I had this problem with a Tekken stick.

On a whim I tried connecting it to my ps2 via a controller extension cable and voila it worked.

I believe for some reason or another the pins inside a controller plug can be pushed back or not make a good connection in the loose ps2 ports.


#4

My friend has this problem too. he borrows my stick and tells me there’s connection problems. it usually works after you unplug then replug it. but there still some problems with the connection.