Problems with a dual-modded PS3 MadCatz Fightstick PRO


#1

Hey SRK, first time poster here on behalf of a friend. He recently got a MadCatz Fightstick PRO (PS3) at Evo, and decided to get it dual-modded for Xbox 360, as well. We only got the chance to try it when we got back, and it works–but it’s apparent something is rotten in the state of Denmark. We’re both newcomers to dual-modding, so we’re hoping to find some insight on what we’ve got on our hands.

I don’t know what PCB it’s using, but on PC (LK+MP+HK) it runs perfectly. Can’t say yet for X360. It’s on this FS PRO’s native system that several issues pop up. If set on LS when plugged in, within seconds the XMB menu invariably goes to the PS3’s Home menu. When this happens, the face buttons (plus start and select) stop working. If set on DP or RS, this doesn’t happen, so I entered a game to see what was up. Curiously, in a game the buttons all work, but simultaneously cause the XMB menu to come up. Directional inputs also produce this effect. Also curious was that two days ago the stick played for about a half-hour before this problem came up, but today it ran smoothly for about a minute. Totally clueless as to why that is. The turbo and lock buttons (and the turbo lights) seem to do nothing, as well, but that feels comparatively minor.

Excuse the blurry pictures, I can always take more.






Is there something we’re missing? Are we just doing this wrong? Or is this as far-out as we think it is?

Apologies if there’s a thread out there for this already–I couldn’t find anything quite like this–and thanks a ton in advance.


#2

Could you take pics with the interior illuminated by some light source. The only things i understand from the pics is that you have a kickass balltop, there’s a rats nest under the hood, there is an unidentified PCB in one of the pics, and the mad catz pcb only has a ground line hooked up (as far as the pics go, but there’s surely more connections there).


#3

PS360+ installed.
Mad Catz PCB not used.

Ground connected to Mad Catz PCB.
Also Signal for Home is connected to Mad Catz PCB.


#4

Doesn’t the mad catz need power hooked up for the home button to work?


#5

No, since its hooked up to the PS360+ the home button is no different from a regular button with both a ground and signal line. I’m just wondering how he’s getting home when the stick is set to LS or if he presses buttons if there’s no other connections other than ground and home signal.


#6

Back with more pictures. Detached another layer to ease identification, as well.



http://i1370.photobucket.com/albums/ag252/zcnaylor77/A%20cracked-out%20stick/IMG-20140720-00116_zpsfe925a29.jpg (The red/white wire runs up past some snipped wiring here. Couldn’t get this to come out clearly)
http://i1370.photobucket.com/albums/ag252/zcnaylor77/A%20cracked-out%20stick/IMG-20140720-00112_zps1231cfef.jpg
http://i1370.photobucket.com/albums/ag252/zcnaylor77/A%20cracked-out%20stick/IMG-20140720-00114_zpsa71ea10f.jpg (You can see the two white wires intersecting here, for whatever that’s worth)
http://i1370.photobucket.com/albums/ag252/zcnaylor77/A%20cracked-out%20stick/IMG-20140720-00115_zps7d4828fc.jpg

Nothing seems terribly out of the ordinary, but hopefully somebody will catch what I’m missing.


#7

If you’re using a button from the stock pcb should it not also have the VCC connected to the PS360+? GND is not enough unless the ‘home’ trace was cut.

Setting the panel to DP, LS, or RS shouldn’t have any effect, same with turbo and lock so it just sounds like either a bad mod or a bad PS360+ board.


#8

Check to see if the trace was cut between the home wire and the chip on the te pcb. The solder point for home will be labeled ‘2’ on the te board.


#9

Thanks for the info. I checked out the trace, and also unscrewed the other PCB to see the underside. It’s a bit messy, maybe, but the solder points all seem secure. Just in case, I took a picture of it.

The circled area is the home wire and its solder point.


#10

No just check it on the te pcb not the ps360+.

There should be a cut mark in the trace between the te blob chip and the soldered wire on the spot with the lable ‘2’.


#11

Ah, my bad. It’s a little gnarly, but the trace on ‘2’ seems unmarked.


#12

Okay. It should of been cut. I could look up if it was vicko or duckie that did the mod, but that’s irrelevant. If you cut the trace on the te circuit between the chip glob and where that wire is soldered then that should fix the input ussue.


#13

Cool, I’ll get on that. Thanks Gummo.


#14

That’s one of mine. Sorry you’re having problems. Gummo is right in that I should have cut the trace between the solder point labeled 2 and the points coming from the chip with the black blob on it. That’s my bad, and cutting that with an x-acto knife will fix it. Just make sure you don’t damage the actual solder point, you’re cutting into the little green ridge that’s BETWEEN those two areas.


#15

Worst case scenario if you botch it some how you can always just hold start and select to get home.


#16

No news means I’m assuming it worked…


#17

I have a PS3 TE with a similar problem, just with a Hori VX board and a ChimpSMD soldered to the home button & USB ground instead of a PS360+. Scoring the lead, as you said, does seem to have fixed it though.

I’m just curious why it worked.


#18

The wire (or a loose solder joint) can wiggle and make a connection between one of the other close points on the board and cause problems. Scoring that lead cuts its connection from the rest of the board.

It’s not anything that actually HAS to be done, it’s just easier to do it and know the problems 100% solved than to not do it and have to deal with the 1 out of every 99 sticks that would have this problem.

In my case, it just had to be that one that I forgot to do. EVO was hectic, man. ^^;


#19

Its because the vcc on the ps3 te pcb isn’t wired up. This leaves the home signal floating which can interfere with what ever you wire up to it. Cutting the trace disconnects the home signal from the chip and thus not left floating.

So either wire up gnd, vcc, and home or just gnd and home and cut the trace.


#20

Good to know, thanks guys.

Y’all really helped me out.
I was going crazy trying to figure out what I did wrong and chasing loose leads.
Pun intended.