Problems with dual mod


#1

If anyone has exp dual modding their xbox360 TE stick i would love your advice, SO first time soldering anything after a week or so of practising dove in to my Chimp kit. Finished it up and hooked it up for a test run worked semi great at first, nothing i couldn’t fix, after restarting to try something else the unit was no longer getting power, so i figured, must be the usb cable since i did a pretty shoddy job soldering them in. Next day i re soldered them, then hooked it back up now when i plug it in all 4 player lights come on, then stay on and the stick isn’t putting out any input. Any suggestions? :I


#2

Check the connecting between the stick and the pcb maybe u moveit and it’s half on


#3

problem solved, now a new problem, when i turn the xbox on with the usb plugged in, the light ring lights up real fast like a second or two, then goes black and i get no response from the stick


#4

I have no experience with the ChImps but I’m going to ask the most basic question.

Is it in 360 mode?


#5

lol.

This might be one of the problems you have. IIRC (I haven’t done my ChImp mod yet), there will be a primary and secondary PCB to select upon the plugging in of your stick. If your ChImp has your secondary (I assume PS3?) PCB as primary on your ChImp (i.e. will select PS3 by default), then your X360 controller will blink a few times and then die out (I’ve had this when I was doing my Cthulhu/X360 mod). To test this out, plug the ChImp into your other console and see if it works there. If so, then when you plug it into your X360, press the button that will make your ChImp start in X360 mode (guide button by default? I’m not sure… depends on how you wired your ChImp).


#6

Little notes to keep in mind:

  1. There is no ‘primary’ or ‘secondary’ on the ChImp like on the Imp.
  2. Do NOT use the lights on the 360 TE LED board for anything; they don’t provide any useful information.

If you’re trying to test out a Chimp installation, the very first thing to do is to test it on a PC. THe control panel applet at least shows the name of the game controller attached, which is frankly more information than you’ll get from either console. As long as the Chimp is assembled properly and the USB cable is connected properly, then you should see the Chimp come up in the game controllers applet. So I guess the steps you should take to test it are:

  1. Plug into a PC, verify the Chimp shows up.
    -if nothing comes up, go through the Chimp troubleshooting guide linked in first post of cthulhu thread.
    -if 360 board shows up and you don’t have the buttons held down when plugged in, test voltage on pins 5 and 6 of the smaller 14 pin chip and pin 1 of the larger chip.
  2. Unplug, and plug back in with Short, Strong, and Roundhouse buttons (1K, 2P, 3K) held down. 360 controller should show up in in the game controllers applet.
  3. Plug into PS3 to test.
    -if 1 and 2 work fine, but doesn’t work on PS3, test voltages on pins 5 and 6 of the smaller 14 pin chip.

#7

/facepalm

I forgot. The goodness of the ChImp is that it automatically detects. Right, right…


#8

Plugging in with no buttons held down brings up PS3/PC chimp on windows, when i plug in with those buttons held down, xbox360 controller shows up. But dosen’t work when i plug into xbox. doesn’t do anything.


#9

Plug it into an Xbox360. Test the voltage on pins 5 and 6 of the smaller chip and write them down (which is which). Unplug, plug it in with the three buttons held down, measure the same voltages. Post up what you find.


#10

Update on status haven’t had time to test with multimeter, but stick worked perfectly with ps3 every button and direction and auto detect etc


#11

Hmm… if X360 still doesn’t work, I wonder if you switched the D+ and D- cables to the ChImp board…


#12

It might be time to take many close up pictures with the macro (flower icon) feature on.


#13

k tested it with multimeter no buttons, pin 5 : 0.01 pin 6 was 5.02 same with the three buttons pressed


#14

pin 14 of the big chip showed 0 and no shorts or bent pins, does that mean bad C2 capacitor


#15

That’s good. That means that the Chimp is autodetecting fine.

If the chimp was having problems in chimp mode on the PC or on a PS3, I’d say yes. Since it works fine on both according to your description, I’d say its fine and your testing was off. Don’t sweat the C2.

If you are still not getting any kind of reaction on a 360 system, but the 360 board is showing up fine on a PC and reacting properly, then I’d expect the problem to be with the security chip on the 360 board. You may be boned and to use a different 360 board. If you want to verify for yourself, connect a USB cable directly to the 360 board by itself, and you should see the exact same problem. Based on everything you’ve written, the chimp itself is working 100%.


#16

Any other tests i can do? Or an area that has a high probability of mistake? The stick worked fine before i opened it up to put it in, and it worked once when i first hooked it up, but never worked on xbox again, the one time it worked the buttons were fine but down was up and up was up, and the home button didn’t work, but plugging it into a ps3 it all worked fine. I was going to check for shorts but i never got it hooked up to 360 again. Any of these help? Will be such a major pain in the ass to have to return this one and reorder another from the store i got it from plus another 2 weeks without a stick in addition to the 1 that mines been non functional.


#17

Is this a bad time to ask if the Lock switch is on?


#18

Tried both on and off :s with each of the switches.


#19

Test it on another Xbox360. If it doesn’t work on a different Xbox360, then yeah, its a problem with the xbox pcb in the stick.


#20

And whats the solution if i wire the usb cable straight into the xbox PCB and it works :stuck_out_tongue: