PS3 home button not working (madcatz)


#1

I have a standard edition sf4 joystick that I bought at a local thrift shop for $7. I hooked it into my ps3 and the stick and buttons work, but the home button doesn’t work. Is this a known problem with these sticks? Does the home button only work with specific games? Should it light up around the turbo or something? Even the start and select buttons work so I really doubt its a PCB issue but all the wires look good. Hopefully I’m just being a noob. Any help is greatly appreciated. Thanks.


#2

Make sure the two switches on the turbo panel are set to ‘DP’ and ‘unlock’.

The quality of the home button design is pretty poor on SE & TE sticks in general, sometimes you need to push the button down hard for it to kick in. Aside from that it could either need cleaning or repair.


#3

How would I go about repairing it? Or would it be best just to sell it and get a Hori or something?


#4

If you have no idea what you’re doing then get a listed modder to look at it. There’s a stickied thread at the top of this forum.


#5

I cracked it open. Never worked on a stick before but I have tons of experience on other controllers and systems. Took out the PCB and cleaned the home button and once I put it all together it worked. Thanks! I just got a completely working stick for $7.