PS3 Madcatz TE Fightstick Not Working On Win10 PC

I’ve been searching all over the web and I simply cannot find an answer to my problem, and yes, it has to do with fightsticks.

I’m on Windows 10. I have the Steam version of Street Fighter V. I have the VIA 2.0 USB card installed in my computer (which worked in getting my PS3 TE1 stick to work with SFIV). I have a PS3 Madcatz TE1 fightstick, as well as a home-built fightstick that shows up as a “ModChipMan Controller” in TocaEdit X360 Controller Emulator.

The home-built controller shows up in the X360 Emulator…inputs are recognized and whatnot. But this stick does not work when SFV is booted up.

The Madcatz controller is registered by Windows as being plugged in, but does not seem to be powered at all. No lights, no inputs being registered…nothing.

When SFV is booted up, there is not any sort of “use legacy controller” option under OPTIONS>MORE OPTIONS.

So has this magnificent group of street fighters figured out how to make these damn things work with SFV yet? I realize that the game is only 3 days old (not counting beta), but I also know that the PC gaming community is brilliant and works fast on aggravations like this. But there’s gotta be a way to make these sticks work!

I have not yet tried Joy2Key, but I don’t have much hope for that utility either at this point…

PS: I really hope that “change the PCB” is not the only solution to this problem. It’s the freaking 21st century, folks…this sort of stuff shouldn’t be an issue at this point.

Use X360CE (the x64 version). Joy2Key probably works too, but I prefer XCE. It’s an Xinput emulator. The easiest way to set it up is to place the X360CE executable in “SteamLibrary\steamapps\common\StreetFighterV\StreetFighterV\Binaries\Win64”. Run it, agree to all prompts regarding creating new files, configure the stick via the GUI, save and close. Your stick will work then.

Hopefully Capcom will patch DInput support soon and this process will become unnecessary.

I did state that I tried the X360CE utility to no avail. I followed all the prompts and created the new files just as you suggested. X360CE shows the Madcatz stick as “PC USB Wired Stick 8838”. However, no inputs are recognized when I move the stick or hit any buttons. And it still doesn’t work in-game.

The home-built stick shows up as “ PS3/PC Controller”. Inputs with this stick ARE recognized by X360CE, but the stick still does nothing in-game.

I can’t find any definitive information as to whether or not it’s Windows 10 that has rendered the Madcatz stick useless or not. I’m leaning that way since the stick doesn’t seem to be powered at all, even though I get the chime from Windows signifying that I plugged it in.

For what it’s worth, windows 10 will not work with the 360 sf4 fight pad I own, nor would it work with the 360 brawlstick pcb I had. A pcb replacement- something with more neutral drivers- would be your best bet IMO. Which one depends on what you want to use the stick on beyond PC, if anything.

I want to point out that the round 1 and round 2 Street Fighter 4 Mad Catz TE for the PS3 The 2 original variants for the PS3 TE does not work with non-intel chipsets as its a matter of USB protocols
These old PS3 Sticks work with UHCI, that newer TE sticks, the TE-S and up work with OHCI.

Also UHCI sticks are not forwards compatible with USB 3.0

They should

theres a thread about ps3 stick windows compatibility that has a link to a specific set of drivers for UHCI devices on windows10. Try searching for it, if it worked under previous windows you can get it to work under win10.

My PC is indeed running an Intel chipset (i5). And yes, it’s true that the UHCI sticks will not work with USB 3.0. But even beyond that the sticks will only work with a VIA USB chipset, which I indeed have installed in my PC. I ran into that problem when I initially tried to get my Madcatz stick to work with SFIV. The $7 VIA USB card fixed that nicely.

Ok, could you try these?

Holy crap…that did it! I swear, I’d buy you a beer if you were here! I now have stick operation on SFV!!

God I love the internet and people smarter than me.

I’m having the same problems as well with a PS3 Madcatz MvC3 version fightstick on Windows 10 Pro 64bit.

I have an Intel Z170 motherboard and I plugged the stick in a USB 2.0 port on the motherboard. The computer recognized the stick but does not register any inputs from the stick. I have tried the batcmd registry edit and tried using x360ce with no luck.

Any suggestions is appreciated. Thanks.

It has to be the VIA chipset USB 2.0 card. The VIA chipset is the only architecture the Madcatz fightsticks will work with to my knowledge.

I think its better to mod the stick that to install a PCI card in your PC.

To each his own, but a USB card install takes about 20 minutes shutdown to startup, and costs $7. How that’s worse than modding the internals of a stick is beyond me.

Alot of people are laptop users or don’t have the PCI slot on the PC any more. PCI slots are being phased out for the smaller PCI-E And trying to find a UCHi complaint PCI card these days are alot harder than just modding the controller. Also the new USB 3.0 cards are not UHCI compatible.

Good points, all. But if you’ve got the slots on a desktop, it’s easier to go that route unless you want to mod in order to future proof yourself.

Thanks for the info. Are there any fight sticks that will work on a PC without any modding? I might want to get a newer stick that will work with the current gen console and PC.

Yes, there is plenty of sticks that work on the PS4 or Xbox One

what do these do? i have a TE2 stick (360 version), and i can’t use it on my Win8.1 PC because it’s unresponsive and drops inputs every couple of seconds. it took forever to even get the system to recognize the stick. would that help with my issue?

I doubt it. Madcatz 360 sticks never used UHCI afaik, and certainly not the TE2.

1 Like

where i can buy a pcb for MADCATZ ARCADE STICK TE for the pc i want to use in tekken 7 pc steam