PS3 Madcatz TE stick not working on PC


#1

I know there is a few people with this problem, but I found out it works fine on my Linux Ubuntu install. So does that rule out hardware problems?

It shows in the ‘devices and printers’ page as PC USB Wired Stick 8838. Street Fighter x Tekken seems to be finding the stick also. When I test the stick in ‘devices and printers’ however it shows it is not picking up on any movements or button presses.

CPU: Intel Core i5 3570K 3.4GHz | GPU: Radeon HD 6950 | Mobo: Asus P8Z77-V LX | RAM: Corsair 8GB (2x4GB) DDR3 1600MHz

EDIT: It is in my USB3 slot also by the way.


#2

bump…


#3

Having the same problem.


#4

The issue that you are having is because the Madcatz TE sticks use an old usb chipset.

Some people have been successful with motionjoy but I was only able to get my PS3 TE stick to work on my PC with the use of another USB pci card.

http://www.newegg.com/Product/Product.aspx?Item=N82E16815287002

Specifically, you need a the “VIA” chipset usb. Simple, cheap, more USBs for your PC and it should work right out of the box with your PC. I didn’t have do anything software wise, just worked right when I plugged it in.

Hopefully this helps!


#5

Okay thanks, I found this: http://www.amazon.co.uk/Port-Card-Cardbus-External-Internal/dp/B002DMU864

Is that okay?


#6

I have purchased a VIA chipset usb for this purpose and it still doesn’t work. http://www.amazon.com/gp/product/B000JFJZGG specifically. I am weary of further purchases.


#7

I’m not sure what to tell you other than to purchase a x360 TE instead.

There is a reason why the x360 TEs are the better purchase :smiley: