PS3 TE Arcade Stick Issue on PC


#1

Hi, my computer has an nvidia chip set, so it is unable to detect my PS3 Madcatz TE arcade stick. My friends have the Xbox 360 TE stick and that works just fine.

Does anyone know if a PS3 to Xbox 360 adapter would work?

Here is the product: Universal Adapter for XBOX360/PS3/PS2/PC USB: http://www.amazon.com/Universal-Adapter-XBOX360-PS3-PS2-USB/dp/B0089OBLDO/ref=pd_bxgy_vg_text_y

Thanks!


#2

You can get a zero delay PCB for less that will definitely work.


#3

Oh ok, can you explain what a PCB is please? Also do you have a link to the product? Thanks!


#4

I have a nvidia chipset as well and I just installed a zero delay PCB from ebay. I’ve been using it for a couple of hours and it works fine. One issue I did find was the commands for the joystick directions were reverse, I unscrewed the joystick and rotated it, solved the problem. Just type in zero delay encoder on ebay but this is the one I bought http://www.ebay.com/itm/171060862728?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649


#5

You could also try a PCI or PCIe (depending on the age of your motherboard) USB card with a VIA chipset.


#6

Sorry about the double post


#7

cool thanks, Was the process to set it up difficult?

Sadly all my PCI slots are taken up on my motherboard so the VIA card is not an option, that would be the easiest fix though :confused:


#8

#9

I tried looking for a video on youtube on how to install this zero delay PCB but couldn’t find anything. Does anyone know a link that for a video or tutorial on how to install this? Thanks!


#10

The process wasn’t difficult. However, I didn’t need the turbo and home panel so that simplified the process. All I did was disconnect the wires connecting to the buttons to replace with the quick disconnects that came with the Zero Delay PCB. Connect those wires into the PCB.


#11

Hey i’m having a similar problem. Only I do not have an Nvidia chipset I have an Intel chipset. It reads the stick is there for about 10 seconds when i first plug it in. but then disappears like I unplugged it. Not sure how it could read it and work, but then just stop…


#12

i would swap it out for a 360 but the fucker i got it from on amazon won’t respond.