PS3 TE Repair Help Needed ($ incentive)


#1

Hello,

  After one of my two TE sticks ceased to be recognized by my PS3 I called Mad Catz and was sent a replacement USB cable and board.  After soldering the cable to the board, hooking up the pins, and putting everything back together, I fired up the PS3 and was relieved to find it recognized again.

 However, after testing  all the buttons and stick in practice mode, I thought I was in the clear until I realized the home button didn't function and the turbos (though I never use them) didn't either.  The switches for the LS DP RS do work, however.  I thought it might be because of dirty contacts on the board, so I opened it back up and cleaned them with rubbing alcohol and a cotton swab.  

  Upon loading SF4 now, however, the menu with "quit game, turn off system, etc." comes up automatically every time and I am unable to back out of it (the home button still doesn't work).  The stick works fine, letting me scroll up and down to choose the options, but I cannot choose one nor exit this menu; all of the buttons cease to function now at this point.

  If anyone can tell me what the problem might be and it leads me to a fully working stick, I'll send you $5 Paypal as a gift.  Anxiously awaiting any advice.  Thanks.

#2

it first sounded like you had the lock switch turned on. Which would explain why the home button didn’t work (don’t know if that would affect the turbo).


#3

Well, the turbos are actually working now, the only problem is that the home button still doesn’t work and the “quit game, turn off system” menu automatically comes up when loading any game from the dashboard and none of the buttons respond when in that menu, only the stick. Still looking for a reason…

Also, when I removed the first board and usb cable, I noticed the two black wires from the cable were soldered together but figured this was a mistake. Are they supposed to be that way or separate like the rest of the contacts?


#4

if its two black cables from the usb cable, then yes they are supost to be that way.


#5

Hah well I have no idea if that would cause the issue I’m having but I’ll tear it back open and see what happens. Be back in a bit.


#6

Just soldered the two blacks together and reassembled it to have the same thing happen all over again…quit game menu just loads when starting a game and I can’t make it go away. This is extremely frustrating.


#7

hook it up to a pc and look to see if all the buttons and directionals are working. you may have a short on your home button or something may be plugged in backwards.


#8

Well, when I was in practice mode everything was working 100% except for the home button, which is why I disassembled the stick again and tried cleaning the contacts for it and the turbo button.

When I’m in the dashboard or searching the PSN store (basically anything but loading a game), everything works fine except for, again, the home button. So, if I were to have a short in it, what could I do, if anything, to fix it? The actual button appears to be only a plastic and rubber pad that pushes down onto a contact on the PCB for activation.


#9

unplug all 3 connectors that go to the turbo/home PCB and see what happens. if you can load the game and run like normal you’ve found your problem.


#10

But if I pull all 3 connectors and then only the USB cable’s left, and it loads properly, what can I do to fix the issue at hand? I mean, none of the buttons or stick being used doesn’t help me out at all. I’m sure the issue lies with the home button somehow since it’s the only one that isn’t functioning.


#11

Up b/c someone out there must know how to fix this and wants $5 to tell me.


#12

This happened to me as well, all buttons worked fine but one day my home button randomly stopped working. No lock was on, but the night prior I had it on, it seemed to just stop registering. I took my case apart checked the connections made sure there was nothing loose and put it back together. I then toggled the lock switch about seven or eight times and it started working again. Bizarre.

I think it has something to do with the lock switch, perhaps it’s not registering on the PCB when you toggle it back and forth.


#13

No, the lock button locks out the turbo button and unlocks it just fine, so that’s not it. The problem is bigger than just one button not working as I can’t even get into a game with the stick plugged in b/c the inescapable menu pops up and won’t go away.