PS3 TE stick on the fritz?


#1

So I just went to hop on ond play BB:CS and my TE stick won’t register. I tried both USB ports and nothing. WHen I press a button the little lights in the turbo panel will blink but nothing else will work. Anyone know what may have happened/how to fix this? It was working perfefctly fine as of last night so I’m really confused:sad:


#2

Same here since a couple of days. For me it happens since updating to the latest firmware. But that also could be simply random. After locking and unlocking the buttons (microswitch) several times, it usually starts up, but completely random. Besides that I don’t trust those damn microswitches. Might be the weakest parts at the whole stick. Solution would be nice.


#3

I did what you said and it works again. I wonder if there is a reason behind this as well. Shit was random and had me oh so sad. Lol


#4

I’ve never had my PS3 stick not work right away when plugging it in.

360 on the other hand wouldn’t suprise me.

Interesting.


#5

It won’t read again now. It worked when I did it last night. I take good care of my stick. I have no clue what screws I need to ger the front panel off to see if something inside might have come loose from playing. This is wierd :sad:


#6

Just all of the hex screws on the top panel
Should be 6 of them

Most likely you wont be able to see what’s wrong. Call madcatz or wait a while longer for some more posts from the geniuses here.


#7

Oh its more than weird. I use the damn thing since about one and a half years. Always had some problems that way. At the start, I had to lock and unlock the buttons or switch from ls to dp just once. Some weeks later had to do it maybe twice. Another couple of weeks later, the stick is ready as soon as booted, now its like I posted above… Somehow I thought it might have changed after each of the several firmware updates during that period, but never examined properly.


#8

Try plugging it into your computer USB and go to the control panel. From there, click on game controller and test out the button inputs. Everything (button inputs) should correspond to a number and test the stick. It sounds like your turbo button was getting stuck, so when you push the buttons, all that would happen would activate the turbo and the LED lights would blink.


#9

I’ll try it but I dunno how my Turbo button would’ve gotten stuck. I never use it.


#10

same phenomenon from ps3 seems too reoccure on pc. First after plugging it into one usb port it doesn’t get recognized since i lock and unlock the buttons for several times. But even after startup the stick won’t notice any input (might be the windows bug).