PS3 TE stick problem, the stick not responsible at all


#1

Hi I have this stick for more than a year and suddently the stick itself has no response at all. The buttons work fine tho. I tried to open the top panel to see if any wire loosen, and I don’t see any problem.

Try to unplug and restart PS3 cannot solve the problem. I’m newbie to tech so I wanna know what problem.

I didn’t mod or open the stick before.

thanks


#2

Is your switch not on DP anymore?
Is it on RS instead of DP?


#3

thanks for your quick reply I didn’t know what is LS-DP-RS before. and my friend accidentally put to RS that’s why not working. I’m a nub cake sorry for my stupid question


#4

hey guys im having this same problem and idk what jdm is talking about cause im a bigger noob :frowning:
i have a te round 1 stick and its like 3 months old and the stick is not working. its not going in any direction!
:[
any help please would be awesome!


#5

@isaacin308

on the top in the turbo box there ls dp and rs

it simulates left stick, d-pad, right stick respectively

if you have the switch on rs it will simulate the right joystick and since the game doesnt use it at all the joystick will basically do nothing.


#6

Yeah. My stick isn’t responsible either. I have to pat it on rear and say, “Bad stick!” Then it finally starts working again.


#7

hey guys i switched it top dp and still nothing! :{
am i gonna have to order a new stick or something?


#8

Did you change anything before it stopped working? Is yours a PS3 TE? or 360? Check all cable connections properly? Dropped your stick on the ground? You might want to divulge any other info you can. Just a heads up.


#9

its a 360 te and i didnt do anything i left for a trip and came back to it not working. all the buttons seem to work fine just not the joystick. it can downback but thats only if im pressing hard enough . i took it apart and couldnt find anything. everything is connected, im just worried i have to replace the actual stick but i thinkk that weird cause i havent haf the stick longer then 3 months. i also put it on DP instead of rs but i tried every option like ls and etc and nothing still.


#10

ill see if i can post a video later


#11

strange. It’s probably your stick. If it only responds to downback as in Down/Left, try switching the way the harness fits on to your joystick. Flip it upside down. Not sure if you took it off, but if you flipped it upside down, only down or left would respond. Give that a shot.