PS360+ and windows 10


#1

Just built my first gaming PC in what feels like forever and have had a hell of a time getting any of my PS360+'s to register in windows 10. I’ve done a good amount of searching on here, and I was unable to find anyone with a problem like this, or a post that had a solution I have not already tried.

Error message in device manager in Universal Seriel Bus Controllers:
Unknown USB Device (Device Descriptor Request Failed)

I’m kind of running out of idea here on what I can do, but this is what I have tried:

  • 3 separate PS360+'s, all the same error.
  • Tried every USB port on the computer as well as thru 2 different hubs (powered and not)
  • Tried more than a few cables (1 six foot, 1 ten foot through a neutrik and 1 directly plugged into the ps360+)
  • Forcing 360 mode by holding down 2P ( or MP, whichever you want to call it)
  • Tried in PS3 mode as well, because why not?

Outside of these, I really don’t know what else I can do. I have several other sticks that I can use on my PC, but I’d really like to be able to use my hitbox for SFV.


#2

I haven’t had any trouble with either ps360+ equipped stick I have on my windows 10 build. Maybe it’s a compatibility issue with your motherboard? Are your other sticks working with it? Are your ps360 boards still working with your old pc? Maybe a firmware update?


#3

Yeah, other sticks are working fine on this PC. The PS360+ sticks work fine on my macbook pro running windows 7 as well.

I’m sure it could be a motherboard issue (not really sure how likely that is though) or from what I’ve been reading that error could be caused by a powersupply with too much power. That just sounds insane to me, so I am writing that one off.

Unfortunately, no searches with ps360+ or my asrock MB come up together anywhere so it seems I am SOL.


#4

I had a lot of issues with the PS360+ on win10 as well. Im not sure if this will resolve your issues, but heres what worked for me:

  1. Use a usb 2.0 hub. My stick wouldnt work through usb 3.0 ports (which is what most new computers have).
  2. Force XB360 mode and it detected / worked fine. If I just plugged it in, it would detect as a PS360+, but would not work for SF5.

Hope this helps.


#5

The USB 2.0 hub isn’t necessary. Yes most newer computers have USB 3.0 ports, but they should still have 2.0 ports as well.
Use a 2.0 port. Also not all USB devices that are compatible with 2.0 ports are 2.0 devices. Some devices are only USB 1.1 which are not compatible with 3.0.

SF5 issue is a problem with SF5 (and how it uses only Xinput) not the stick.


#6

I tried a USB 2.0 hub as well and its the same thing.

One other thing I noticed is on my hitbox, I can switch it to use the Hori FC4 and the pc will recognize it. Obviously it doesn’t work with SFV, but it does see it.
I just want to use my hitbox on PC :frowning:

If I have to I guess I can just order the brooke PCB and see if that works. Just sucks because I have several ps360+ sticks that I won’t be able to use apparently.


#7

My solution was to plug the stick / PCB into my monitor (USB 3), but you already said you tried a powered hub, so I am surprised that you haven’t gotten it to work. Have you tried adjusting the USB power settings in your BIOS and in the Device Manager?


#8

Did both. Still no dice.

This is beyond infuriating.

Just to test I updated the firmware to the newest version on my laptop without any problems. All 3 of my laptops I’ve tested this on had absolutely no problems recognizing the ps360.

On my hitbox I have it modded with a ps360 and a fc4 for ps4 usage. The fc4 has no problems being recognized on my new computer, just when I put it in ps360 mode it screws up. Hopefully sfv will have support for the fc4 when it releases or I’m going to throw these freaking sticks out the window.


#9

Update: Ordered a new powered USB2.0 hub and for some magical reason, it worked. Part of me is happy I finally got it working, part of me is just throwing my hands up screaming WTF.


#10

@“deaded by panda” hey i know you already found a resolution but have you tried the alternate 360 forced mode. its 2P+2K. I had the same error as you with the 2P forced mode but this worked for me. It was part of the 1.65 update:

Ver. 1.65 (Official Release)
Changes:
Added forced Xbox 360 mode (2P+2K) for people who have a problem using
the PS360+ in Xbox 360 mode on PC/Mac.

One weird thing that its doing for my setup is that in this alternate mode it swapped RT(3K) and LB(4P) - easy fix in the SFV controller settings but its just something to note. Try it out and lemme know if it works for you.


#11

IIRC 2p+2k ALSO activates oldschool xbox support (the one from early 2000’s) … just using 2P activates the xbox360 support iirc.

i noticed this when using this mode on my laptop running linux :slight_smile: