PS360+ and Windows7 64-bit issues

I’m in the process of fitting my Madcatz SFxT stick with a PS360+. All’s going well so far, just doing the most basic installation - got it hooked up to my PS3 and everything is working perfectly (I’ve not had a chance to test on an Xbox360 but I’m assuming that it will be likewise working as the PS3 mode is working). However, the board isn’t registering at all when I hook it up to my PC.

I’ve tried connecting the stick and letting it auto-detect the platform, forcing PS3/PC mode, forcing Xbox360 mode, loading in Bootloader moded … nothing registers on my PC. I’m running Windows 7 64-bit. I’ve tried installing the Atmel drivers but windows fails to actually install them, claiming they’re not signed for 64-bit … this is all a bit strange to me because if I plug in an actual 360 pad, it works perfectly. Yet connecting the PS360+ in force-Xbox360 mode doesn’t work. It just shows up in device manager as an “Unknown Device”

Any ideas what might be wrong here?

Why are you running Atmel drivers just to use a PS360+ on your PC.
By default the board should of gone to PS3 mode which is Plug and Play with the genetic drivers your PC has pre-installed for HID class devices.

First uninstall what ever bull crap you already installed for drivers and restart your machine.
And if you have to go into device manager and uninstall your stick there.

Once your PC has rebooted, and you logged back into windows, allow windows to autodetect and install its own drivers.
Done. Don’t force Xbox 360 Mode (you need the MS Xbox 360 Wired game pad drivers *(for the MS made Xbox 360 wired game pad) *for all your Xbox 360 sticks)

Undo whatever drivers you installed. Install the latest firmware for the PS360+ (instructions are on the website), and that usually solves the problem you’re running into.

Older firmware had an issue where it simply would not work on certain PCs or Xbox360s for unknown reasons. I updated the firmware, and now it works 100%.

I installed them to flash the PS360+ firmware to the latest version (as per the instructions on their site), but they fail to even install on 64-bit windows.

“Should” have, yes. However, on 64-bit it looks like the device isn’t recognised by default. The first thing I did with the board was plug it into my PC - which registered it as an “Unknown Device” before I started doing anything else.

Well no, because windows doesn’t recognise the hardware to install the drivers…

I have the MS Xbox360 pad drivers installed, it made no difference.

I have this same issue, it’s driving me insane.

Seems like I have this issue as well. Got a 64-bit PC running Windows 7 - I keep getting “USB device not recognized” whenever I plug my new Hitbox in, regardless of whether I let the PS360+ autodetect, force PC/PS3 mode, or force 360 mode since I have the drivers for 360 controllers installed. No dice.

The interesting thing is, I have a 32-bit toaster running Vista that I used to run SF4 on a while ago; plugged the Hitbox into that, installed just fine. To me this indicates the PS360+ has some sort of issue with 64-bit systems, but those are so prevalent nowadays you’d think there would be more people complaining about this issue if it was actually that simple.

Uninstall the current drivers you have, upgrade the firmware on the PS360+, and try again. That often resolves the problem. I’m running my PS360+ on my 64-bit W7 just fine.

When you say “current drivers”, are you referring to the 360 controller drivers, or something else?

I haven’t attempted to upgrade the PS360+'s firmware yet. I’ll try that and see how it goes, thanks.

Current drivers = the 360 controller drivers you currently have on your PC.

i had some issues at first. i believe it was with the latest ps360+ drivers and went to a previous one but i can’t remember for sure (i think it’s v1.3). a strange thing i notice is that if you boot windows with the stick plugged in then it is recognized as an xbox device, but if you unplug it and plug back again it is recognized as PS360+ game controller.

i forgot to post this. i assume you may have tried this but the win xp version worked for me even though i run win7 64. there is a “windows” section which i assume is for win7/etc.

Since my Windows 7 machine couldn’t recognize my PS360+ even in bootloader mode, I had to upgrade the firmware to the newest revision (1.31) via my older Vista box. Still didn’t work. I’d think since the PCB itself is pretty new (it’s in a hitbox I purchased off the guys just this past weekend), it’d already have the latest firmware on it anyway.

I’ll try downgrading the firmware to 1.3 and seeing how that goes.

EDIT: Update: Downgraded the firmware to both 1.3 and 1.23 (the previous version before 1.3) - still getting “USB device not recognized” on my Windows 7 machine.

I have 2x ps360+ on windows 7 64bit.
If you go to devices and printers not device manager does it have icons for them labeled ps360+ ? Mine has an entry for each of my ps360+ labeled
"PS360+ v1.3" even though they are v1.31

Try forcing windows to search for drivers for the device while connected to the net, and ensuring it is not in bootloader mode. That is only time it should appear as an Amtel device.

Nope, mine just has it labeled as “Unknown Device.” Trying to update its driver merely tells me the driver is “already up to date.”

Under Properties > Device status, I get “Windows has stopped this device because it has reported problems. (Code 43)”. Googling that code indicates that it’s either a problem with my PS360+ itself - unlikely since I already made sure it works on another PC and my 360 - or a problem with one or more of my PC’s drivers. I find it interesting that no matter if I force the PS360+ into PS3/PC, 360, or even bootloader mode, I get the same code 43 and the same “Unknown Device” label.

EDIT: Thought about the problem a little more. I thought maybe if I could manually set the driver Windows uses for the PS360+ to “HID-compliant USB game controller” - since that’s what driver my toaster (on which the PS360+ is working just fine) assigns it, maybe that would fix the problem. I can’t seem to find that driver under the dialog where you can manually choose what driver to use for a device (Devices and Printers > right-click relevant device > Properties > Hardware > Properties > Update Driver… > Browse my computer for driver software > Let me pick from a list of device drivers on my computer

EDIT #2: I was wrong when I said my toaster is a 32-bit Vista machine; it’s actually a 64-bit Vista machine. This is all really confusing.

maybe turn off all other programs and firewalls before plugging it in. it’s odd that it will detect on one of your machines but not the other. re-install the drivers and make sure you have Administrator privileges or just turn off windows security while installing.

Another piece of info: I’ve got a Mayflash Wii-to-USB adapter I use for playing some emulated games on. Windows 7 correctly identifies it as an HID-compliant USB game controller, which is the exact same driver the PS360+ should be using. Curiouser and curiouser.

I’ve read that some motherboards have issues with longer cables, usually around the 15ft mark, which is exactly the length of the one my Hitbox came with. Anyone think replacing the USB cable on my Hitbox with a shorter one might be a good idea?

i’ve heard that longer cables have an effect on response time but you never know. hopefully someone more knowledgeable can answer. usb cables aren’t that expensive but it would suck to spend the money and have that fail too.

Yes Longer cables may have a change in response time, but we are talking miscue amounts of time

According to Rear Admiral Grace Hopper US Navy Officer and Computer scientist a if you take a 11.8 inches long piece of wire at the speed a electron moves (near light speeds), it take that electron 1 nanosecond (one billionth of one second) to go from one end of the wire to the other.

We at SRK measure lag in Milliseconds is a thousandth of a second. And a millisecond is too short for human perception to pick up.
1 ms: time for a neuron in human brain to fire one impulse and return to rest
100–400 ms (=0.1–0.4 s): Blink of an eye
18–300 ms (=0.02–0.3 s): Human reflex response to visual stimuli

Absolutely. Ideally you should have 10 feet or smaller USB cables. Some drivers/boards don’t deal with the noise induced from longer cables well.

Crack open the hitbox and grab a shorter cable to sanity check

Well I think the quality of the cable comes into factor too.

The Dollar Store special 10’ USB cord is going to have more interference than the Monoprice 10’ USB cable

I also regard the stock cords on Hori, Mad Catz and Qanba sticks to be completely crap.

did you ever figure this out? im having the EXACT same issue - i can load it up fine on another win7 machine and i updated the firmware that way… but on my win7 machine i just cant get it to recognize

ive uninstalled and reinstalled everything under the sun

EDIT: Just to flesh this out a bit more.

PS360+ modded TE works fine with xbox and ps3, but when plugging into my personal windows 7 ultimate pc i immediately get ‘usb device not recognized’

My wife has a windows 7 ultimate pc as well - plug that in and it works fine. That is how I was able to update the firmware (its an older ps360+, pre-release from a few years back, didn’t use it that frequently) to 1.31… but I need it to work on my PC.

Truth be told the only difference in the builds between the computers are the motherboards - i have a msi z87-g41 pc mate and shes rocking an asus (who’s model eludes me at the moment)

I’ve uninstalled the usb drivers, updated what I had from MSI, tried all different configurations… tried loading in all different modes, but just can’t get it to do anything but detect as an Unknown Device… SUPER frustrating