PS360+ Firmware update for Mac


#1

Issue resolved I didnt put a space after the word “flash” when i drag and dropped the hex file from my desktop into terminal. PS3/360 work great with auto detection now, but for the Dreamcast I have to hold 3P inorder for the stick to be detected by the Dreamcast.

Below was my orginal post:

I wired up my PCB and tested it on my Xbox/PS3 and everything worked fine until I tried to update the firmware to OfficialVer1.23.hex and now I can not use it on either system.

I was able to detect the ps360+ bootloader in terminal (Step 3) so I assume I did everything right up until that point.

https://dl.dropbox.com/u/99864654/ps360%2B/Screen%20Shot%202013-01-08%20at%206.12.54%20PM.png

Step 4. Erase the PS360+
sudo dfu-programmer atmega32u4 erase

https://dl.dropbox.com/u/99864654/ps360%2B/Screen%20Shot%202013-01-08%20at%206.22.48%20PM.png

Step 5. Flash the PS360+
Write in the Terminal (and afterwards hit enter):
sudo dfu-programmer atmega32u4 flash “name of file”.hex
(Do not include the quotation marks when you write the name of your file)

I was unsure how to direct the path in terminal so I just dragged and dropped the file after i pasted the line: sudo dfu-programmer atmega32u4 flash
than hit enter. You must have a space after the word “flash” in terminal for this to work issue resolved.
**

https://dl.dropbox.com/u/99864654/ps360%2B/Screen%20Shot%202013-01-08%20at%206.33.02%20PM.png

**


#2

If any first time mac users need help upgrading their firmware, I will try to help.

One thing i wanted to mention…I originally downloaded Xcode from the App store, installed it
and than tried running the sudo code (Step 1 and it failed after hitting return and gave me some error).

I think you need to download Xcode command tool lines from https://developer.apple.com/
separately (can someone confirm if this is the only thing you need to download?) before you run Step 1 from the Akishop pdf. This wasn’t clear in Akishop’s pdf but it worked only after I downloaded the command tools separately.


#3

Hey, thanks for your post! <br><br>Think that they should modify their .PDF with your info. Also they skipped some steps, like, as you’ve said, download the command tool lines (you can download them from  Xcode ----> preferences -----> downloads), and also have to run Xcode before using the terminal.<br>