PS360 & my Unknown USB device detected problems


#1

I have with me two PS360 boards that both seem to be in tip top shape. I have now wired both of them and am getting the same “An unknown USB device is detected” error.

I can’t find a FAQ for the PS360 and I’m hoping there is an easy way to know what I’m screwing up. I’m using an 11 button set-up with the Select wired with the Turbo. I’ve tried to do the holding Select/Turbo and plugging in the controller to switch the mode thing, but it still is saying it’s unknown.

Help me please! I’m so close I can feel it with my teeth.


#2

It could be a damaged wire or loose wire with the USB cable.


#3

either that or he mixed up or has a loose connection with his data signals


#4

I’ve done two of them back to back after the first didn’t work. Since both didn’t work I figured it was something I did unless they both somehow broke via transit. I have past experience in soldering to a PS1 controller and it worked first try so this can’t be anything hard since I just plug it all in and screw it in. Is there a list somewhere of things that cause “Unknown USB Device” errors? Long shots are fun to find in a treasure chest somewhere.


#5

Is it giving you this error on only one console or both?

Edit: Or are you trying this on PC?


#6

The time I received my PS360 I kind of wired it wrong with the Madcatz PS3 PCB and it was acting weirdly like not switching to PS3 mode and if it did it would sometimes put Unknown USB device. After that I tested out the PS360 by itself and the switching problem eventually went away. It also turns out that it is sometimes picky with USB ports. Most often it works on the USB ports of PCs that are at the backplate and would sometimes bug out on the USB ports that are connected to the front part of the PC case. I properly wired the Madcatz PS3 PCB with the PS360 and haven’t had a problem with switching and Unknown Device since.


#7

Sometimes, as i’ve recently discovered it could a simple matter of cheap/faulty USB cable. I had a printer that would not be recognized by the computer, switched the cable to a gold plated one (from monoprice) and it worked no problems… basically what Darksakul said :slight_smile:


#8

I guess I shoulda been more specific. I’ve only tired them in my PS3, and since they are being detected, just not at controllers, I figured it was something easy. I’ve tried two of the cables to connect and still nothing. Do you only get “unknown USB device detected” if it’s not switching over to the different mode? Should I try wiring Turbo by itself?

Just for some boards that were supposed to be plug and play, I could have soldered two PS1 pads by now…

EDIT: Also, both cables work when connecting my printer to my computer. So I’m pretty sure it’s not the cables.


#9

By default they are sent with 360 mode active, they do not auto-detect. You should test on your PC before moving further to get absolute feedback. Just make sure you have the 360 controller drivers installed.

Chances are it’s in 360 mode and you just need to wire the turbo button by itself (not select or anything else, just turbo) to test switching modes with ONLY a USB cable attached and running to your PC.


#10

Yeah after I posted I hooked the one I have wired up to my computer with a completely different UBS cable and it downloaded the 360 drivers, and then let me switch over to PS3 mode. I don’t know if it’s the different USB cable or that I switched it to PS3 mode on my computer but it now works on my PS3.

Thanks a shit ton guys. I thought my arcade cabinet dreams were about to go up in smoke.

EDIT: Is there a reason why my PC will detect the Select/Turbo buttons wired together, but not on the PS3? I don’t own a 360 so I can’t test that until my brother comes over.


#11

Bumping with a new question that I can’t find an answer to. I have a 80g backwards compatible PS3 and, though PS1 games will work, no PS2 game I run will recognize the two controllers. Hitting Home doesn’t bring up the system menu, and only my PS3 controller will turn on basically. Is there anything I can really do?


#12

Bumping one last time for my question.