PS360+ stopped registering on ps3,360 and PC


#1

Last night at my group’s weekly, my beloved MAS stick stopped working right after i had finished a match. I went to plug it back in on the ps3 it did not work. I went to try it out on xbox 360 and it did not work. Today i tried nothing worked, now my PC isn’t even recognizing it. What do i do?


#2

Who installed the PS360+?

When you say it did not work, can you be more descriptive? Absolutely nothing turns on?

If so, then its most likely the USB A-B cable fell out of its port on the PS360+ PCB. If it does turn on, but does not function properly, then you have a problem with installation.


#3

I’ve been playing on it consistently for several weeks. . Its rj-45 to usb and its actually plugged into the PCB it is not loose in any way shape or form.


#4

Try plugging it into your PC while holding down Start. IIRC, that should trigger BootLoader mode… If your PC does not detect a “new” device, then I’d say that something is wrong on board… But I would also try disconnecting the RJ45 and try with a USB cable to make sure your cable didn’t go bad.


#5

i was only given an rj45 to usb cable. I tried doing what you said with the bootloader and none of my inputs or anything is registering for Sf4.


#6

i really hope its just a cable, i don’t want to have to fork out more money for something to fix with an arcade stick. I already bought a brand new joystick for my other stick, i thasn’t come in yet. So right now i can’t practice at all or play anything.


#7

Do you have a usb cable for a printer (USB-B)? Try unplugging the RJ-45 and using that. If that works, it’s the cable.


#8

Yep it was the cable. thanks again guys :smiley:


#9

Awesome… Come to think of it, my last suggestion should’ve been my first! :stuck_out_tongue: