PS360+ Xbox mode not working properly


#1

Hey guys!

I posted in the HitBox thread and after contacting AkiShop with no luck in getting any useful feedback (told me they were too busy working on PS4 support but “would look into it”), I was wondering if anyone here could help me out or at least let me know if it’s a problem they’ve experienced or heard about before.

Basically, whenever my controller is plugged into any Xbox, it’ll randomly drop buttons pressed at the same time and instead output them as individual button presses. I recorded a video, hopefully you can hear that I’m pressing the buttons at the same by the sound (the inputs don’t even show it plinked, so there’d have to be a noticable gap inbetween), but I can guarantee that it’s a problem specific to the Xbox mode as I’ve tested it on PC and it works perfectly fine on it. I’ve tried replugging and restarting the Xbox many times and it’s always the same thing and always works great on PC. This bug on Xbox makes feinting and doing EX moves so inconsistent the game is flat out unplayable for me, sometimes it will happen several times in a row and other times it’ll not happen for maybe 15 seconds or so. It’s pretty frustrating when I’ve bought an Xbox + XBL mainly to play AE and now it’s just sitting there.

https://www.youtube.com/watch?v=bUNvkPyhoCk

Since it’s specific to the Xbox mode, I figure it can’t be the wiring or anything like that, but I’m not really sure what I can do to solve it. I tried updating the firmware already with no luck. Any ideas?

Thanks!


#2

Easiest thing to eliminate as a possibility would be to try a different cable.


Need a good tek-innovation hitbox layout (or any good layout)
#3

I’m using the same cable as before I installed PS360+ and again it’s working fine with the same cable when I’m in the PC mode. Can it still be the cable that will work in one mode but not the other? I don’t have another one of this type of USB cable lying around, but if it’s likely that’s where the problem comes from I’ll get my hands on one.


#4

I’ve read here that consoles are more finicky about cable problems than pc’s. Might not be your problem here, but it’s worth trying.


#5

Noticed this yesterday as well while practicing some stuff in marvel on 360. Mine isn’t up to date. Does your ps360 have the newest firmware?

Edit: Didn’t see the text below the vid when I read it on my phone…


#6

I think it is the PS360+ that is finicky with USB cables.


#7

I will also add that my cable and board are brand new as I bought them three weeks ago from Focus Attack. A quick question does it make a difference to which port out you use on the ps360 board Rj45 or USB?


#8

Not really. RJ45 gets less interference that regular USB, its really based on the quality of USB cable you have.


#9

I am SO glad somebody posted this. You aren’t going crazy, I can confirm the same issue. It’s been driving me insane for weeks, and I’ve tried everything from changing buttons, changing wires, doing a direct connection, downgrading back to 1.20 from 1.31, with absolutely no luck. Yes, I am using RJ-45 as well, though I had the same issue on USB.

I did extensive testing on this using the Xbox 360 version of SSF4, as well as the PC version. The quickest way to test this is to go to training mode on the PC version, enable input display, force PC mode on your stick, then try plinking with strong ~ jab. Comes out perfect every time. Unplug your stick, force Xbox 360 mode, and you will notice tons of split inputs when simultaneous buttons are pressed. It happens randomly, and there is no set pattern to it.

This issue is so devastating that I’ve gone ahead and restored my Razer Atrox back to it’s original PCB. Absolutely no issues with plinking, kara’ing, or anything else. PC/PS3 mode works fine on the PS360+, but there is a definite bug with simultaneous button presses on the Xbox 360. It’s a shame because I really want to use the PS360+, but with all tournaments running standard on Xbox 360, it’s too big of a risk to use right now.

Some scenarios this bug affects:

Kara throws
Plinking
EX moves
FADCs
Throw techs


#10

Thanks for posting guys, it’s good to hear it isn’t just me making excuses. I really encourage everyone here to post their issues directly to Akishop, because they seemed to not really take the problem seriously, and of course not recommend the product to anyone until they fix it, as it was recommended to me.

Appreciate your input FourWude, I was just about to order an RJ-45 cable to see if it’d fix it, but clearly it has to be a problem with the firmware. If that’s the case though, I really can’t believe it’s such a highly regarded product. It’s something everyone owning it would’ve noticed by now I’d imagine, and shouldn’t be a problem specific to a few of us.

Either way, it’s definitely too inconsistent to play on for now. Hopefully enough people will report it for them to look into it.


#11

Weird thing about this issue in umvc3 is that the game still accepts the split double inputs normally.


#12

Hmm. if you run both signals to a single button, and try this out do you see it as well? This would be an exact simultaneous press situation, with no human error to cause “randomness.”

Not saying there’s no bug, but if you’re PLinking inputs perhaps you aren’t doing it as consistent as you think? Sounds like there’s a difference between modes, and perhaps it’s a polling rate issue.


#13

It causes an issue with plinking, but the main issue is a result of pressing two buttons at once. It will split the inputs randomly. There is definitely something going on, because swapping on the fly between PC and Xbox mode shows different results. Setting the PS360+ to PC mode on AE’s PC version gives me identical performance to my Razer PCB, which is Xbox only. Likewise, my stock Razer PCB has no issues when used on the 360. I’d really love to admit that this is a user error (so that I can use my PS360+), but the execution requirements to test this are very minor.

PS360+ set to PC mode on AE PC version = no issues
Razer PCB used as 360 controller on AE PC version, or 360 version = no issues
PS360+ set to 360 mode, used on PC or 360 = random split inputs on simultaneous button presses


#14

You’d know if the board split it randomly if you tied two inputs to one button and hammered it. Telling me to Plink two inputs doesn’t give me anything, because if I’m slightly off… no matter how good I think I am at plinking, it becomes skewed data. This is especially true when trying to Plink and use a game engine bug to define and prove out an issue.

If it doesn’t split any more, it’s a polling issue and when you are pressing the buttons is dancing on a poll, so if your second button you are trying to press is slightly off it gets missed and moved into the next report. See what I’m getting at? Again, I’m not saying there’s no issue, but let’s be clear about the difference between something actively splitting a report and it polling inputs in a manner that’s causing you issues.


#15

I understand. I should have been more clear though. It will also split inputs that are meant to be together. Such as EX moves, throws, FADCs, etc. It’s not a plink-specific issue, I just used it as an example.

I’ll see what I can do about the test.


#16

So is this only an issue on a few of the ps360 boards? Can someone who thinks they have a properly functioning ps360 please go into training mode on an xbox360 and throw some ex hadoukens or just dash around in marvel to see if inputs are split. @Phreakazoid‌ I’ll try to out your suggestion this weekend when I have some free time.


#17

I would but I don’t have SF for the 360.


#18

I’ve been using a PS360+ for my main stick for a while now, and while I don’t have the chance to check out the training mode now, I will say that I’ve had no issues playing SF4 or UMvC3 with EX/Focus/Supers, etc…


#19

I’ve used one in one of my main sticks for well… years now, and haven’t had issues. Even beyond to games with stricter timing like guilty gear for FRC inputs.


#20

Hi there.
I bought the board two months ago. I have the same problem.

Since nobody has reported this problem for years before this thread, it seems to me that only recently manufactured boards are defective.