PS4 HitBox Update Not Updating


Hey people! I have an older PS4 HitBox and I am trying to update to the 5/4/17 firmware. Every time I start it up and click “Update,” the window displays the word “Updating”, but then the program locks up. I get the “(Not Responding)” tag in the window name and I have to force the program to close. I am holding the PS Button before plugging it in to my PC, I’ve even restarted my computer and selected “Run as Administrator,” and it keeps doing the same thing. Any advice would be greatly appreciated!

As an afterthought, I did mistakenly download the official fix for newer HitBoxes and tried to update with that, but it also kept telling me that the “Update Failed.” I am at a total loss as to what to do next.


I don’t think the latest firmware works period, and the one they said they were going to post on 5/5 is still on the back of a milk carton. Given we’re about 2 hours away from Injustice’s release and a couple weeks past when this really should have already been fixed I’m pretty pissed off right now.


Something like that sounds like a problem with your PC… Program Not Responding. I would go into Safe Mode in Windows and try to do the update from there.

Edit: BTW I can confirm that the update is working for other people.


were you able to ever get this working? i have one of the first ps4/pc hitboxes and have recently tried using it on my ps4 for injustice and i get the 8 minute timeout. no firmware update i’ve tried has worked whatsoever. i actually dont even get an update button. on windows 10, tried 2 different devices, tried different firmware installers, etc. nothing at all.


I tried the update on my PC at work and everything seemed to work fine. My HitBox doesn’t timeout anymore. It probably is an issue with my PC… RIP


What OS were you running at work?


Where is the update for the ps4 hitbox? I haven’t used mine in forever.