Ps4 to switch brook converter with wii u firmware

Hello I heard that people can get help with brook super converters here. I have a PS3 PS4 to switch converter, and I have put PS4 to wii u firmware on it before. And it worked then, but that was a long time ago. I tried putting xbox360 to wii u firmware on it only for it not to work. So I tried putting the ps4 firmware back on it, now it doesn’t work. It keeps flashing green while in my laptop, and doesn’t recognize the controller. I’ve tried updating it with and without the controller, removing the device from my pc and running as administrator.

Nothing works, please help.

If you have a ps3/ps4 to switch adapter and tried flashing it with a xb360/one to switch firmware, there is a good chance that you bricked your adapter. Those are 2 very different devices and the firmwares are not interchangable.


Is there anyway to fix it? Or do I need to buy a new adapter.

Your best bet would be to buy a new one. It might me worth contacting brook support for help. But they are notoriously unresponsive.