Qanba Q4 RAF - Square/X button not responding


#1

Yesterday I changed the artwork on my Qanba for the first time. When I finally got everything put back together my square(ps3)/x(xbox) button was not working at all. I tried switching the buttons around and it still didn’t work. The black wire connected to the button is working fine, I switched it with a black wire on another button and that button still worked so I assumed it was the yellow. I had that wire tested today and the guy who did it said that the wire was working although I’m still not sure.

I found a previous thread where someone was having the same issue but they also had the third comment in the thread which just said “Nevermind, it’s working again” which doesn’t really help me. It sounds like it’s not that serious an issue to fix though.

I really want to get this working before SFxT comes out.

Here are some pictures. Sorry if they don’t help at all. It’s hard to focus on things that small with an iphone. If someone really needs me to, I can remove the wire restraints and upload a video.


#2

Can somebody please offer some help. I have no idea what’s wrong.


#3

Take the two wires from a working button and connect them to problematic one. Test if the button is working. If not, you have a broken button. If it is, take the wires that are originally connected to the unresponsive button and connect them to a working button. See if the previously working button still works. If not, the problem might be with the wire or the PCB. Test the continuity of the wires by using a multimeter and see if they’re broken.


#4

please try as messenger suggested.
afterwards, send those pictures including a description of your problem and the test results to mr. zhong from qanba: zhongxianglong@hotmail.com. you will get help and - if needed - replacement parts.


#5

Thanks, M3SS3NG3R and paxos! I tested the button on different wires and it worked so it looks like the problem is the wire most likely. I was planning on putting some seimitsu buttons on my stick so I decided to order those and I’m gonna see if replacing the buttons solves my problem, even though I’m fairly sure it’s the wire. I’ll post here after I’ve tried the new buttons.

paxos, will Mr. Zhong still help me even if I’ve opened my stick and changed the artwork? Or will I need to buy the replacement parts? Worst case scenario, I’ll need a new PCB.


#6

you will get the necessary replacement parts in any case as long as the problem stems from faulty original parts and not damage done on your part :-).


#7

I talked to Mr. Zhong and he was very helpful and shipped me a new pcb. Out of curiosity, do you know long it usually takes for replacement parts to arrive?


#8

could be 10-20 days, so be patient :).


#9

I just got a Blackout edition Qanba 4RAF a month ago, and though ArcadeShock says there’s no way it could be happening, it is causing MK2011 to desynchronize on both systems consistently. When I play with the game pads or another stick it does not desynch at all. Soon as I plug in the Qanba and play, it desynchs. Anyone ever hear of this or have any input?

EDIT
**Apparently it is the button mapping that desynchronizes the game online. When I use the defaults it does not desynch. **