Qanba Q4RAF problem with RT button


#1

Hi, I have already posted on the Qanba thread as well, but i figure some of the more experienced tech talkers don’t go in there.

So here’s the problem.

The RT button is randomly being activated. Whether the button is plugged in or not. I have inspected everything i can on the stick and have hit a wall. I have no idea what can be causing this. Any tips on how i can further diagnose the problem or fix it?

It also triggers when i disconnect the button harness from the PCB. Does this mean it is the PCB???

When i unplug the USB cable from the stick’s pcb and plug it back in it stops for a minute. But not if i unplug it from the console and plug it back in


#2

Being a PCB problem is possible, but also check around to see if there are random pieces of metal in the case that might be causing them to touch the PCB and cause a short. If you have a multimeter handy, you could cheack around for short circuits between the two points, but generally this thing only happens as a wiring issue when someone tries to mod, especially Dual Mod, but Q4RAF is already dual modded, so you don’t need to be doing that.


#3

I shall inspect the stick for small pieces of metal that could cause interference.

Update: I really don’t see anything that could cause any interference.


#4

have you tried to connect another button to the RT cables?
can you post some detailed photos of the inside?


#5

Yes, i’ve tried that, and it still activates the RT button on it’s own. I could e-mail you some pics if you like, but everything looks just like the inside of yours! lolz.


#6

the problem has been solved.

FYI: the problem was that the ground wires weren’t connected correctly. the solution therefore was easy: nakadish only had to connect the black grounding wires with only 2 connections to the RT and LT buttons. and voilà, it works again.


#7

I’m having the same issue as the OP, the RT button seems to go off automatically when on xbox, but works perfectly fine on my PS3. Also kinda new to the fight stick so I’m not really sure what wires paxos’ post is referring to.

Can post pictures if needed.


#8

inside the stick, there are some black wires that electrically ground the buttons. these black wires come from 2 different cable strings. the RT and LT buttons have to be connected to the cable string from which only 2 black wires originate.


#9

Thanks for the response paxos, but somehow the issue seemed to resolve itself. After leaving the fight stick off for a few hours then trying again later that night it seemed to start working perfectly again. Not really sure what happened, but all is good now.


#10

just PM me if the problem occurs again.


#11

Will do, thanks.


#12

i got the same problem with the lt bouton …