Questions of making a Custom Stick


#1

Hey, I’m new here and was just had a few questions before making my stick. First was where I could get the buttons. I have a TE Fightstick and like the buttons, but not the colors, so wondered if there was a place that I could. Next was that my TE is broken, what I’m asking is what is wrong with it. It seems all the buttons work but for some reason the joystick will not work properly. If I remember right, it goes left instead of right and vice versa. Can I just buy a replacement, and which one? Thanks ahead of time for those who tried answering. If links are available, please post them as well. :pleased:


#2

open stick. there should be a wire plugged into the stick. Unplug, turn upside down, plug back in.

for buttons - there’s lots of places. Look for “SANWA SNAP IN”


#3

Yes, what you have told me would be common sence, which I did do. It did not work and I called them and they told me the same thing. But I was too lazy and I think it is too late for me to call back to get it fixed.


#4

maybe you’re plugging it in backwards or upside down?

as for the buttons… there are a number of places. personally, i usually order from gamingnow.net. but lizardlick.com also sells some.


#5

I will just say this, I have tried every way I could. It really upsets me that it wont work.


#6

I would like you to describe to me the problem with your Joystick more.
Saying that it goes Left instead of Right does not say anything to me.

And problem is not with the Connector being plugged in wrong.
If the Joystick PCB has Connector facing to right, and Wire Harness plugged in upside-down, then ONLY Down would work.


#7

Here are some pictures since I cant put them in words.


#8

Does anyone know how to help me?


#9

try this, it kinda sucks but anyway.

hold the control panel vertical with all the harnesses still plugged in. with your console on, hold the harness to the joystick in extremely firm with one hand and move the joystick with the other. it may be the harness. it was for mine


#10

Bump


#11

Perhaps it isn’t working because there is no PCB? The spot where your pcb is supposed to be is empty.