R2 and L2 not working in PS3 MvC3


#1

I have this weird problem with my dual modded wireless TE Fightstick with Leo v2 and LED buttons.
The R2 and L2 buttons do not respond in MvC3 on my PS3. I have tried it on Mortal Kombat and SF Alpha 2 and they work. I also play on the XB360 and the buttons work flawlessly playing MvC3 with that system. This is weird because it works on all other games but just not the PS3 version of MvC3. I also noticed it won’t work on the PS3 keyboard on screen, example… To make upper case letters I need to press R2 it won’t respond. I also tried my ps3 version of MvC3 with other controllers and R2 and L2 does work.

If you have any ideas on how to try solve and fix this problem let me know.
I really appreciate the help. Thanks!


#2

I believe you have a problem with the “solder” on the ps3 PCB that´s why it work fine on your x-box and it doesn’t on the ps3.

you can also see a similar problem here: http://shoryuken.com/f177/button-issue-hrap-v3-sa-mvc3-266426/


#3

Yes, it is a known problem with the Leo v2 and some games including MvC3. :sad:


#4

It works on my Ps3, just not with MvC3 for some reason.

Do you know what else games? Because I was thinking about getting SSF4 for the PS3 too. I guess this will be my main stick for XBOX 360 wireless. Sucks to hear there are some problems with some games though, its weird cause it works with Mortal Kombat and Street Fighter Alpha 2. Does this pertain to only PS3 games or Both systems?


#5

Only PlayStation 3.

It is the Leo v2.
You have it for Wireless.
Gummowned installed for your Dual Mod.


#6

It will work fine for SSF4 and HDR for ps3. Was a problem that wasnt discovered until long after I made the leo1 and leo2.


#7

Is there going to be a fix or work around for this? I guess I am more interested in WHY doesn’t it work? Anyone know why?