Real Arcade Pro 2 SA "UP" not working


#1

I’ve had my SA for a couple months now and used it sparingly with no problems whatsoever. I bought HD remix for my PS3 and decided to try my SA with it, using a Pelican PS2 / PS3 converter. I’ve never had any problems with this converter, whether it be hooked up to my PS3 or my PC. Anyway, I started to play with my bro, he’s using a Soul Cal Hori stick, and we begin to play. At the character select screen, it tells me that I need to reconnect my controller, even though it had been working just fine right before that. So I disconnect, and reconnect it and start it up. To my surprise, I can’t jump at all, but everything else works, directions and button presses.

I take it to my PS2 and try it there, and still, the Up direction will not work, but everything else will.

This is what I think may be wrong:

My PCB be fried from the converter (which I am now afraid to try with my other joysticks)

Static electricity shorted it out? Is that a possibility?

I am going to open it up this weekend and see whats up, but would anyone have any idea what might’ve happened? Anyone else experienced this problem using their joysticks with this Pelican PS2/PS3 converter?

If it DID short out, what would the best way to go as to fix it? I was going to just replace the whole PCB with new PS2 controller PCB only if I have no other option.

Thanks!


#2

Try replacing the TP-MA first. Its the pcb that sits in the JLF. If that doesnt work then you probably fried the pcb.


#3

What kind of PCB do I replace it with? I am not sure where to go with that TP-MA. Do I buy another joystick and replace it with that one?


#4

Here you go. Halfway down the page you’ll see what I’m talking about its the TP-MA.


#5

Try seeing if you accidentally toggled the Guitar Hero switch on the side.


#6

Thanks, they sold out there, so I went to akihibara and bought one there.

Nah, I’ve already put it into my PS2 and tried some games, still same problem. Ya think it was the converters fault?


#7

if the converter blew the PCB, it probably did it in a really weird way.

The way that PCBs typically die is all or nothing, but it’s certainly possible and probably has happened. I’d jumper the up position and ground lines and see if it still works. The solution then would be to replace the PCB with the switches.


#8

http://forums.shoryuken.com/showthread.php?t=172537

Check that thread out.


#9

Well, in those cases their entire stick stopped working, and it was plugged directly into their systems, not through some third-party converter.

Thanks for the advice, I will try this out hopefully sometime today and let you know what happens.


#10

Okay, so I finally got a new TP-MA for my HRAP 2 SA, replaced it and to my surprise, it still DOESN’T work. Apparently its not the TP-MA PCB thats not working.

What else could I check to see whats going on? I plugged it into my comp with a converter and confirmed that the microswitches work on all buttons except for that one switch, even WITH the new TP-MA installed into the sanwa stick.

Are there any other tests or suggestions I could try to see why everything else is working EXCEPT that one input? Im guessing there is something wrong with the main PCB itself. I have the main PCB all opened up and stuff, and I can take pics and post them if its necessary.

Again, thanks for the help.


#11

if the wire’ing from stick to mainpcb is good then its mostly like your mainpcb is defect …


#12

Really? It just boggles me that ONE direction may have fried or defected, and not ALL of it. Like what Taiki, it’s usually all or nothing… grrrr

I’ll try to run a few more connectivity tests from the main PCB it self, and see whats going on there. Maybe the wire from the “D” microswitch to the PCB has gone bad, I’ll try to replace that and see if it works.

I so don’t wanna buy a new stick for my PS2, this HRAP2 was my baby :confused:


#13

just be sure to check all wire’ing … if its the pcb you dont need to buy a new stick … just get a MC Cthulhu (mc version should work with ps2 too) from toodles and replace it with the old pcb …


#14

Well, I guess I should just convert it to a PS3 stick all together. Thanks for the heads up on that Cthulhu board.