Really weird issues on my arcade cab!


#1

Hello everybody,

I’m just wondering, is it possible for an arcade cabinet to be screwed up and not play sounds only on CERTAIN GAMES? I know it sounds funny, but my new (old) cab doesn’t play sound out of certain games, that I know for a fact had great sound the last time I tried. SO either, these boards have just all of a sudden broke, or, the cabinet favors sound of certain games over others.

To be more specific, this is a Taito Egret 29. What possibilities am i dealing with here? The games I am not getting sound on are:

Killer Instinct
Mighty! Pang
Tetris the Grandmaster 2

These worked FINE in a different cabinet I used to own.

So is it a common problem that certain games (that are in perfect condition) will be lacking sound on a cabinet in which certain other games work just fine?

This is so frustrating. I hope somebody can help me soon!


#2

Yes, a couple of things could cause it. Some games have pins for a stereo sound (left, right, and audio ground) while some have only mono sound in the same pins the left and right are for the others. Some boards have the audio amplifier on the board, while others expect the cabinet to have it.

You need to dig into your cabinet to figure out how the audio is wired up, then dig into the manuals for those boards to figure out how their audio is wired up.

And of course, those are newer boards, so they may have a volume adjustment on the board themselves, but the cabinet (nice, BTW. Those Egret’s are pretty) also has an audio amplifier on board that may need volume adjustment.


#3

I don’t know if this helps, but to give popular games that will or will not work, it seems that the 2 CPS1 games that i own work perfectly, but the one cps2 game that I own does NOT. Do these use different power supplies? What is different about these two systems?


#4

On the CPS2 have you checked the sound output type in the config menu? Make sure it isn’t trying to use Qsound stereo for instance.