Replacemnts PCb/Button terminal For Madcatz Ps3 TE Stick


#1

Hi All,
Hope I’m posting the right place does anyone know of any online outlets that has replacement or upgrade parts for the Madcatz TE Arcade stick? Its like this the start and select terminal do not respond to button presses. Its not the buttons swapped terminals with the kicks and punches and they work any suggestions. I live in the Caribbean and therefore am limited in terms of options. Any help would be appreciated. Thx in advance.

Regards

Str8pull


#2

On the TE, the 8 face buttons are 30 mm push buttons and the Start and Select are 24 mm.
Any 24 mm Sanwa or Seimitsu buttons will work as replacement Start and Select buttons on the TE.


#3

First thanks for the reply.Sorry bad explaining on my part the buttons are fine the terminal connection is what seems to be malfunctioning. I disconnected both kicks and punches and tried the Start and select buttons on those terminal and they worked which brings me to conclude that the terminals themselves are faulty. Hope i am making it clear.

Regards
Str8pull


#4

Oh that. There should be no actual components on the button terminal board other than the disconnects for each wire and the spot where the ribbon cables connect the button terminal board to the main PCB.

You can bypass the button terminal board and solder directly to the Main PCB.

Question do you have a Round 1, Round 2 or a TE-S Stick?
The TE-S as a Tournament lock, if it is in the lock position the start and select will not work. Simply place the switch back to unlock.


#5

That’s what I was going to say too. There’s practically no way for start +select to stop working at the PCB level, unless you went in gung Ho with a Sharp instrument, or failed during a dual mod.

OP: you have tested the buttons work - does that include testing the cables the buttons are connected to? That’s about the only thing I can suggest above what D has said so eloquently above.


#6

I have A TE-S


#7

did you test the lock switch?


#8

Dark,
Thanks it seems being the noob that I am I overlooked that lock setting everything is working now must’ve accidentally slipped into that position when I was inside it last time.
Thanks A Heap boss Respect


#9

Thanks Ebeno1 and RT it was the lock switch.