RJ-45 Multi Console Cthulhu Arcade Stick Tutorial Ver.2

Yep, 2.3.

Sorry - if you’re sure you’ve got the plugs (SNES and RJ45) the right way round as shown in the pics then I don’t know what else to suggest. You’ve already checked the continuity so hopefully someone else can provide a bit of helpful insight.

2.3 Cool.
Thanks for your input anyway:tup:
Yeah, im afraid to say 100% the cable is correct. im no expert but im as sure as i can be as i have checked the continuity several times.

Just to confirm, i have it set up like:

snes------rj45-------mc cthulhu
1-------------1--------------G
4-------------4--------------C
5-------------7--------------F
6-------------2--------------A
7-------------8--------------V

8 Button Joystick wiring as follows: (Start, Select, 3 punches and 3 kicks)

Button---------- mc cthulhu
Start----------------Start
Select-------------Select
1----------------------1P
2----------------------2P
3----------------------3P
4----------------------1K
5----------------------2K
6----------------------3K

Control Panel Button Layout as follows:

---------------------------------(start)----(1)—(2)—(3)
(Joystk)
--------------------------------(select)—(4)—(5)—(6)

Once again any help or advice would be greatley appreciated
Regards

You need to check for shorts between the columns, with and without the cable connected. The MC is seeing a different console than the SNES and trying to act appropriately, and the SNES is seeing the gobledlygook and misinterpreting. Either some of the wires in the RJ-45 cable are intermittantly loose (bitch to track down), or there is a short bridging two or more of the columns, causing the Cthulhu to misinterpret what its connected to.

And just for testing, it’s always more reliable to plug in the cord when the system is running than to have it plugged in and then powering on the system. Should work that way, sure, but for initial testing, console on and then plug in.

Hey Toodles, thanks for your Help.
Sorry but im a noob and only know how to do a continuity test. o_O
How would i go about checking for shorts between the columns?
Kind Regards

Check for continuity between G and A. Then G and B, G to C, G to D, G to E, G to F.
Then check for continuity between A and B, A and C, A and D, A and E, A and F.
Then B and C, then B and D, then B and E…
See the pattern? You’re looking for continuity between any pair of columns except V.
If you find one, check again without the cable plugged in. If its still there, its somewhere inside the stick. If not, its in the cable.

I’ve never seen that pad.
Two things you must figure out using a multimeter.

  1. Is it common ground? Check for continuity for ground between where the black wire is soldered on usb to each of the buttons. If it beeps on one side for all buttons and directions then it is common ground and yes you can use it. If not then no, you cannot.

  2. If you want to use the triggers, are the triggers active High or Active low? For the triggers if active high you will have to invert them. If low you only have to use resistors. This is too complicated for me to explain in more detail, so I’ll provide links to webpages that discuss this.
    http://slagcoin.com/joystick/pcb_wiring.html
    How to padhack an 08/09 Madcatz 4716 Common Ground Xbox 360 Pad

Just a heads up to all rigging up wires using GameCube extension cables.
I bought a set of Cube extension cables on eBay (a pack of 2, sold by user “mxqtech”, item #300573152704, if it helps any).
Tried to wire one of them up using the “extension cable” wire-pinout on the first page, no dice.
Wired the second one following the “GBA-to-GC cable” wire-pinout from Mit’s post, and it works (if it helps any, the wires 1-2-3 according to Mit’s original post were red-white-blue in my cables).

I’m not sure what signs anyone could use to figure out which of the two layouts to use, though.

How many pins were in the extension cable?

There were 6 pins inside, if I remember correctly, and 7 wires; the last wire was connected to the outer surface of the plug.
I checked that each of the 6 pins were actually connected to one wire each.

How did you check? I’ve been popping open the female end of the extension cord and matching the pins to the wire colors.

I cut off the female side, so that I had the male-end-plug, the long cable, and the batch of smaller inner wires spread out in front of me. Used my ghetto conductivity tester (a small breadboard with a couple of wires, a battery, resistor, and an LED) to poke around to check which pin mapped to which wire. That way, I don’t have to “mirror” my pin numbers when looking at the female end of the plug to map to the male end.

What I do is after popping off the plastic housing of the female end, I plug the connector into the male side. That way I can look at it as if looking at the male end, and easily distinguish the wire colors for the pins.

Ah, makes sense. Thanks for the tip; I’ll keep that in mind the next time when (or “if”) I have to do another wire.

I just want to let you guys know, after 4 wasted RJ45 plugs and many hours of reading and scratching my head, I finally created a gamecube cable for my MC.

I was having a lot of trouble because I was using the pin guides on this thread. However, those pinouts did not work for me (and some other combo). The cable I am using I cut from my Hori Soul Calibur II stick (which the MCC mod is in now). In order to find the correct wires needed, I inserted a ethernet cable into the stick, stripped the end and exposed wires 1, 7 and 8. I then cut the end off the hori cable and exposed all the ends and started matching three wires to the ethernet cable until I got a connection. The working result was yellow, red and white. I took the cable back to the multimeter and found those wires match pins 1, 2 and 4 respectively. I tested, verified and reverified this.

Here is my pinout for gamecube cable. I will re-re-verify later.

http://img507.imageshack.us/img507/633/dsc1655.jpg

Grab a first party wired controller, and test in a game to see if you can get rumble.
The pin recommended for power, the green one according to your description, is a +5v voltage source intended for rumble motors. The one you’re using is the +3v meant to power the controller. If you can’t get the rumble to work on legit controllers, then there may be a blown fuse in your gamecube/wii. But, hey, if it works, go to town.

Yes, the rumble works. On both my first party and third party controller. I explicitly tested rumble as part of the troubleshooting when I was making the cable. These wires were the only combo that gave me a working connection to the cube. There is no known defect on my gamecube, AFAIK (It has never given me a problem).

Ok I just finished making my PSX cable for my Cthulhu. But I do not have a PSX/PS2 to test it. But I do have the etokki Xbox 360 converter. I plugged the cable into the convert and it worked perfectly on the xbox360. No lag at all.

And then… I realized I nullified the purpose of both the pad hack and the imp board with the etokki converter. This makes doing MC mods with xbox360 support WAY easier and way cheaper.

If anyone is wondering about those Neutrik cable end boots. You can get them on Amazon from here. Only 2 colors though, black and silver.

http://www.amazon.com/Neutrik-NE8MC-B-Ethercon-Cable-Housing/dp/B00067JSSM/ref=pd_bxgy_e_img_c

http://www.amazon.com/Neutrik-NE8MC-Ethercon-Housing-Nickel/dp/B00067JSSC/ref=pd_cp_e_2

They also sell just the Silver pass threw RJ-45 jacks on Amazon aswell. Sorry no black.

http://www.amazon.com/Neutrik-NE8FDP-Ethercon-Through-Connector/dp/B00067JSTG/ref=pd_bxgy_e_img_b

Hope that helps.
Happy modding! :smiley:

thanks for this :slight_smile:

I’m really having a hard time getting this crimping to work. I finally managed to learn how to succesfully put in the wires into the right slot of the rj45, I have confimed that the rj45 pins make proper connections to the usb end (im starting with this, but will move onto a saturn and DC cable later). But despite the multimeter saying that there is a connection, my PC won’t even see it .

I now noticed on all my crimped plugs, both pins for both datalines are connected to eachothe, if this is not how its supposed to be, any tips on how to prevent it? I keep short metal tips on the wires and when putting the plug into the crimper, i try and keep the lines pushed in to keep them in place till I press on the crimper to force it all in place. But appearantly it doesnt work.