Round 2 TE problems


#1

Hey guys-I’m having some issues with my Round 2 TE (PS3 model), and was hoping someone might be able to help me out. I bought it last Summer and it has worked fine up until today. I plugged it in, and my PS3 recognized it, but it scrolls down to the bottom of whatever menu I’m on, then it won’t recognize any other inputs I put in. Has anyone else had this problem? I’m guessing I’m going to have to take advantage of the warranty from Mad Catz for this one. Thanks in advance for any tips/help!


#2

might be a bad microswitch…check to make sure the switch is on DP… open the TE from the top and plug in the controller… when it starts scrolling down like you explain disconnect the wiring harness connected to the JLF… if it stops try pushing a button and see if it accepts the command.
if it stops scrolling when you disconnect the wiring harness you know its possible the JLF thats bad.
if it still happens then its possible it is the PCB.
if you still dont get a button input then it is very possible its the PCB.

if you think it is the JLF cause it stopped scrolling when you disconnected the wiring harness and you DO get something when you push a button I would change out the microswitch on the JLF. its fairly cheap and not hard at all to replace.

good luck finding the problem. hopefully it is just a microswitch gone bad.


#3

I don’t know if it may help you, but I will just Copy/Paste this from one of my previous posts. Maybe D-pad just decalibrated.

I don’t know what is the trick with the Madcatz, but as for Logitech, just hold down R1+R2+L1+L2 and then plug in the stick into USB. This will reset the pad positions and all will be fine. Worked for me a couple of times.
If you are unsure what are those buttons, just hold all 8 buttons and plug in the USB - then wait 2-3 sec and release the buttons.


#4

Hey Blindwithonearm-I just tested it, and after I disconnected the wiring harness it kept scrolling. What would you recommend I do to fix the PCB?