Sanwa JLF/Madcatz SE install gone wrong.. HELP! Lol


#1

Sup guys,

Yah this is my first post here and I’m already asking for help, lol… Anyways, I am a huge SF fan and picked up SF4 a few weeks ago. After watching a bunch of youtube vid’s I decided to take the plunge and pickup a Madcatz SE and a Sanwa JLF and buttons.

The stock stick worked decently for 2 days and just stopped working randomly in the middle of a game. Now I was expecting it to break sooner than later, so I wasn’t concerned. Basically I can move the stick in 8 directions but nothing happens…

So yesterday my box of parts came in, and I installed the new Sanwa stick hoping that this was the issue. It’s a Sanwa JLF, which I bought from a reputable dealer. But after I installed it I had the same exact problem :sad:

So now I figured it’s possible that it’s not the sanwa stick, but possibly the “motherboard” on the SE controller. But oddly enough the buttons work still, so how could it be the motherboard?

Installing the stick isn’t exactly rocket science, so I’m like 99.99% positive that it wasn’t my bad doing the installation. Is there anything that can be done to get this thing working? I don’t mind picking up more parts if I have to in order to get this stick functioning.

I appreciate the input in advance. Thanks alot guys!!

-Bodie


#2

It sounds like either your PCB is bad or when you pulled the wiring harness out maybe one of the wires came out and is not making contact.

The wiring harness is what you plug into your JLF.


#3

Yah if the PCB is bad, I can gut a PS3 controller and do some soldering, no? I’ve been searching around and saw teh CTULHU… Think thats a more viable option buddy?


#4

I think it’s your wiring harness.


#5

I used the stock one from the SE fightstick… It’s funny how like all the sudden in the middle of a game, the stock stick died, so I have no idea what it is… :-(… I’m gonna have to order some parts I guess…


#6

I am having problems installing the Sanwa JLF joystick i recently bought from gamingnow.net

Only **1 direction **works on the joystick. I am using a wire harness.

I checked and all my connections are good and my PBC is good. I tried my old stick and everything works fine.

The new Sanwa JLF stick maybe has defective micros switches?

Anyone have this problem before???


#7

Try installing with the Mad Catz SE Wire Harness flipped?


#8

Do what jdm714 said. Flip the harness however it’s plugged in as of now so that it’s upside-down. Obviously if this fixes it, then it was upside down and put in wrong to begin with. However, if this doesn’t fix the problem, something else could be off. I doubt its the JLF though. It’s brand-new. Might be the PCB.

Bodie21, try doing the same thing up there. Although if you’re joystick still doesn’t work in which case my bad. flip it back over, then the PCB is probably the problem. Even with a harness that’s put in wrong, the JLF usually reads at least 1 direction. Usually down. Also you DID rotate the PCB on the Sanwa JLF right? lol. Just checking on that one.


#9

I have a similar problem with my SE stick except mine reads all directions except anything to do with left, up/left, down/left. What I was wondering is do you still have to rotate the PCB even with the JLF-TP-8YT-SK. I thought the SK (which is what I have) was a drop in placement for the SE. But I’m confused thou because if it was a defected PCB then why are all the buttons and other directions registering but left on the stick. I’m hoping to get this one figured out but probably gonna have to call madcatz Monday and see if they can do anything even thou I’ve opened it.

PS - I got a wiring harness with my stick if it is the wiring how can I install the harness I got into the SE stick?


#10

If you were to rotate the PCB on JLF-TP-8YT-SK, then it would be back to a JLF-TP-8T+(SK).
-SK has nothing to do with problem.

Here the six variations listed in Sanwa Catalog:
JLF-TP-8 is Base JLF.
JLF-TP-8Y is Base JLF with the TP-MA (PCB) rotated 90.
JLF-TP-8T is Base JLF with JLF-P1 (Flat Mounting Plate).
JLF-TP-8YT is Base JLF with the TP-MA (PCB) rotated 90 with JLF-P1 (Flat Mounting Plate).
JLF-TP-8S is Base JLF with the TP-MA (PCB) rotated 90 with JLF-P1-S (S Mounting Plate).
JLF-TP-8Y-SK is Base JLF with the TP-MA (PCB) rotated 90 with JLF-CD (Shaft Cover).

Of course other variations can be done too.

nerbie, your problem could be a defect Microswitch.
Maybe the Signal Wire for the affected Microswitch.

Try this out.
Rotate your PCB and test see which directions work.
If LEFT is still not working, then it is Wire.
If DOWN is not working after rotating, then it would be Microswitch.

If you are going to replace the Mad Catz SE Wire Harness with the one you have, then Splicing will be done.
You will cut off the end of SE Harness that connects to SE PCB.
Connect/solder the cut off SE white connector to your Wire Harness.


#11

Thanks man good info there. I actually got it working again it was the SE harness so I cut the wires open and spliced the harness the JLF came with and the SE one and now everything is ship shape. Hopefully nothing will come lose but I know how to fix it if it does thanks for the help!