Sanwa JLF problems with SE mod, help!


#1

I got the SE and bought Sanwa buttons and a JLF for it from lizardlick. I got it in the parts in the mail 2 days ago and I swapped in the buttons and they worked fine. However, when I swapped in the crappy joystick for the JLF, the JLF only worked in the down position. I thought I maybe put it in wrong so I switched it back to the madcatz joystick, but that worked fine. I don’t think the problem is the wiring harness, because the madcatz joystick works completely fine. I talked to lizardlick and they said I’d have to send back the pcb, but I don’t want to wait even longer and perhaps find out that it wasn’t even the pcb and that it was something else…
any reason for why the JLF could be doing this? is it really the wiring harness? it’s so irritating to have to wait for another wiring harness and then solder it. ugh.


#2

Did you put the wiring harness on backward on the JLF?


#3

i tried both ways. :confused:


#4

can you take the picture of your JLF installed?


#5

Thanks everyone, but after a couple more tries, somehow it decided to work. :slight_smile:


#6

Maybe you didn’t let the harness click in. But if it’s working now, no worries!


#7

If it was anything like my own, it could have been the glue that was used to keep the original joystick connected. There was so much on it that once I tried to reconnect it, the glue was actually getting pushed inside the connector and blocking the connections. For a while there left and down wasn’t working and after reconnecting it several times it finally worked.