SCV MadCatz PC issues


#1

I have a Soul Calibur V MadCatz fight stick for xbox 360 and I can’t get it to work on my PC. When I plug it in the Xbox power buttons lights up for half a second then goes off. I have the xbox wired driver downloaded and I’ve tried using xpadder, however that didn’t recognize any controllers being connected. I’ve looked around the internet and finally decided to give up and just ask, so if anyone knows or can help me at all, I’d much appreciate it.


#2

sounds like a faulty USB cable… check it on 360 first tho… see if it does the same thing…


#3

It is working fine on the 360

Edit: I just tried uninstalling it in my device manager, and when I went to plug it in again, it’s saying that no driver was found. Shouldn’t it be running off the 360 wired controller driver? I’m not very sure about how that works, is there a way to manually make it run on the correct driver?


#4

I recently had the same issue and ultimately had to figure it out on my own. This is how I fixed it on Windows 7.

First install the Xbox 360 Controller drivers, and find the folder where it’s installed. For me it was in C:\Program Files\Microsoft Xbox 360 Accessories

Go to Devices and Printers >> Right-click Fightstick icon >> Properties >> Hardware tab >> Properties >> Driver tab >> Click Update Driver… >> Click Browse my computer for driver software

At this point you want to point it to the Microsoft Xbox 360 Accessories folder, check the Include subfolders box, then click Next. Now your Fightstick will use the 360 controller’s drivers.

I hope this works for you too, it was a serious pain in the butt trying to fix.


#5

Guess that wasn’t it after all, my fightstick is under unspecified and when I go through all that the Update Driver button is grayed out. So I went to device manager to do basically the same thing, and I get “Windows was unable to install your SoulCalibur V FighStick TE”

The worst part is, I don’t know if it’s my PC or my FightStick at this point.


#6

Hmm, I wonder why it’s grayed out. Are you running Windows as Administrator (or have admin priviledges)? Are you current on all your Windows updates? Before I fixed it my Fightstick was also under Unspecified.


#7

Yea I am running as Admin, and I’m fairly positive Windows is up to date.