SE FightStick RT and LT not working on PC (360)

I thumbed though the first few pages of Tech Talk and didn’t really see anything… tried to search but the set limit is something like 28 years…

Anyways, while the control panel Game Controllers registers the button, GGXX#R and Xpadder does not register the button being pressed.

GGXX#R also doesn’t recognize start, or the triggers so its impossible to go back to the main menu with out quitting out, can’t soft reset and can’t back out of a game.

Xpadder does at first recognize the trigger buttons, to map it to the image, but when you try to bind it later and use in a game it no longer works. I tried to use the trigger tab but it just backs out.

Imagine this is caused by the buttons being triggers and not being mapped right.
(Thanks madcatz!)

Anyone else had this issue and maybe have a solution?

Do you have the PS3 or 360 version? If it’s the 360, you may want to try installing the 360 controller drivers.

Oh, sorry, its 360… and I have drivers. Just seems like some apps don’t recognize the R/LT buttons.

GGXX#R thinks that Back is R2.

And you didn’t hear it from me but ZSNES recognizes everything.

Oh, the left and RT triggers are treated as Z-axis I bet. That’s probably why, since they aren’t treated as buttons.

You can use JoyToKey to (and make sure you go to the other tab and check “Use Axes other than X or Y”) set the triggers to a keyboard button.

Get XBCD and remap the LT and RT to be discrete buttons rather than the Z Axis.

I can’t get my stick to come up as the device that XBCD needs. I’ve uninstalled my Microsoft drivers over and over to no avail. It keeps coming up as an Xbox controller.

Couldn’t find a more recent post on the subject. I was googling around and stumbled upon this thread shortly before I figured out how to get the triggers working with xpadder. Hopefully this isn’t a repost of old information, but searching SRK and extensive googling didn’t turn up anything newer, so /shrug.

Anyway, I’m using an XBox TE Fightstick and the official XBox 360 Controller for Windows driver with Xpadder. I imagine most people who’ve tried this have ended up in a similar situation. Everything works fine and dandy except the triggers - Xpadder detects them as buttons when you press them, and everything seems fine, except they don’t work outside of Xpadder.

So here’s what you do.

In your config window, open the Triggers tab, and click Enable. This will bring up a prompt to hold down the left trigger. Instead, hit Cancel.

http://onehitcombo.net/img/tefightsticktriggers1.PNG

This leaves the Triggers enabled, whereas if you had tried to hold the trigger it would have backed out and disabled them.

Select the following options for each trigger using the dropdown boxes:

http://onehitcombo.net/img/tefightsticktriggers2.PNG

then press each trigger button to verify that they’re working. Position them on your layout, save, then bind them to a key and voila! You’ve got functional trigger buttons.

Hopefully this helps someone.

You need to add some information about the stick to the driver’s inf file. For my TE S I used:


%XBCD_360.DeviceDesc%			=Install,		USB\VID_0738&PID_F738		; MadCatz Street Fighter IV Fight Stick TE 'S' 

The device ID was taken from the device manager.

My troubles were actually not the triggers (those were also an issue, though) but the d-pad not sending d-pad events, just POV hat ones. And with the Microsoft drivers the games wouldn’t recognize it set to LS, whereas with XBCD it does.

I contacted MarkMan with a request for information needed to do these for all of MadCatz’s current fightsticks and fightpads (mainly interested in doing them for the Linux userspace driver) but never received a reply.

You are the man!! very nice thnaks!

Thanks circuitious it got the LT and RT working, though your image is no longer working, so what am I supposed to choose when you say “select the following options for each trigger in the dropdown boxes” ? Thanks

Does anyone know how to get xpadder to work with mame? I am on mame UI320.132