SE Stick Cthulhu Mod Problems


#1

So I have modded my x360 SE stick with a MC cthulhu and a RJ45 mod. It has been working well until the other night.
First the joystick stopped responding for a moment. Then once I got that up and running again it seemed okay for a day. Then the light kick(x360: A ps3: X) stopped working altogether. It was all downhill from there. After I checked to see if a wire had come loose(it had not. and no shorts) The whole stick stopped functioning. Now it can boot up PS3 with no light kick use but if I hit the guide button the whole thing shuts down again until I reconnect it. Anyone run into this before or have any trouble shooting ideas. So far it has been multimetered to check for shorts/power issues and its all coming up okay.
Thanks in advance


#2

If you anyone would like pictures of the stick please ask I can post them. Originally the stick wasn’t fully functional as the x360 side of it didn’t work even though when we soldered a usb cord to the pcb it worked perfectly. Although probably unrelated during a tournament some smuck tried to plug it into the back of the PS3 (god knows why). So we changed the usb via quick disconnect cord. I think I’m going to try to plug directly into the MC board next to see if that works.

Any and all help with this issue would be greatly appreciated.


#3

Really need help with this people please.


#4

You’d like help, I understand that. I also understand that you’ve decided to post three days ago about a problem, without any good information on what the problem is. That you haven’t gone through the Cthulhu troubleshooting guide linked in the first post of the Cthulhu thread (URL in sig). That you haven’t posted up those pictures. That you haven’t even indicated what was used for the xbox360 side of things. That you left out information on how its wired up (Imp/DPDT/two USB cords).

If all you can start off with is ‘It doesn’t work’, all we can reply with is 'You’re doing it wrong.


#5

Sorry. Im kinda new to all this. The 360 side is the PCB from the SE stick. That and the MC are linked via an imp. After going through and checking for shorts/power or chip issues everything came up clean. I am going to be trying to desolder the whole thing and resoldering this week when my case comes in. Unfortunately my stick is not at the house right now but once I have access I will post pictures.


#6

http://img638.imageshack.us/g/dscn0078.jpg/
http://img691.imageshack.us/img691/2333/0414001440a.jpg

Here is are pictures of the MC board by itself from a couple angles sorry for the quality I don’t have a good quality camera.

When plugged in directly from the USB port on it, it still says the A(1K) is being pressed.


#7

It is completely separate from anything else now. There are no other pcb’s or the imp hooked up and even with nothing else on it is saying the button is being pressed at all times.


#8

so with no wires connected to the cthulhu and just plugging a USB cable into the board to a PC, the computer is showing 1k as being active?


#9

Yes it is. When I hooked up the cthulu up with the firewire to usb the 1k was shown as being active.


#10

So the problem is 1K (button 2 IIRC on a PC) is always lit up on the PC? Grab a multimeter, plug the cthulhu in, and test the voltage on the 1K screw terminal, and pin 25 of the big chip.


#11

Sorry for such a noob question, but do you mean you want me to put the multimeter on both the 1k and the 25 pin, or do VCC to 1K and VCC to 25pin, also I am assuming by pin you mean the chip this in the middle off the board? Also which one is the 25th pin? where does it start?


#12

First post of the cthulhu thread has a link to the chimp troubleshooting guide. All of your questions are answered there.


#13

The voltage for the 1k screw terminal is .920 avg. The 25 pin is the same.


#14

Have you been able to successfully update the firmware on it?


#15

Is there a way to do the update without having buttons on it? I mean if I have to I can just use the screw terminals quick, just wondering if there another way.


#16

use two pieces of wire, one connecting select to start, and the other connecting start to GND. It should come us as the bootloader then if you plug it in that way.


#17

Updated to the latest and still shows the 2 being pressed.


#18

That’s beyond odd. One last thing: Pop out the chip that’s in it, set your multimeter to test resistance, for 20k ohm if your meter doesn’t autorange. You should see a specific resistance between the 1k screw terminal and the VCC screw terminal, probably 8.2k, 10.0k, or 12.0k ohms. Then do the same check between the 1k screw terminal and one of the GND screw terminals. It may show some resistance, it may show low resistance, or it may show infinite resistance. Let me know what you read between the 1K screw terminal and the GND terminal and we’ll get you fixed up.


#19

Stupid question maybe, but whats the best way to pop the chip out? Lift from both sides, life one side then the other? Is there a lock mechanism?


#20

There’s no lock, you just want to work it out gently to not mangle the pins beyond repair. I usually use a the tip of a sharp knife or a precision flat blade screw driver, and work it between the chip and socket. Start with the end closest to the USB jack since its the most difficult to deal with. Work the blade in so its up a couple of millimeters, then the other end so its up a for millimeters, and repeat. Once the chip is up a couple a millimeters on both ends, get the small screwdriver all of the way in and try to lift the chip up all of the way at once, using the blade to apply upwards force in the middle of the chip.