SF IV Regular Fight-stick Dead


#1

My SF IV Regular Fight-stick suddenly stopped responding: the buttons, the stick, the home button. It seems like its from the wiring. I opened it up and looked inside, but the wires are all in place. Even though neither the buttons nor the stick are responding, when I push the Turbo button and hit a button, the lights indicating the Turbo come on and off. That was yesterday. Today I tried it and it worked, but I was holding it like a new-born baby careful not to move it or the wire too much; and when I made a sudden movement, it went out again. What’s the problem?


#2

the problem might be the pcb. looks like pcb is dying.


#3

can the pcb be replaced?


#4

Yeah you can try calling Madcatz and seeing if they’ll send you a replacement. Another option is to buy a Cthulu from Toodles.


#5

any guides out there to replacing the pcb on a TE/SE? :slight_smile:


#6

And just incase you forgot…it’s Mad Catz. This normally happens to everyone who purchases a Mad Catz Special Edition stick and doesn’t mod it. You’re lucky the buttons weren’t already defective before you even opened the box like some people’s sticks were.


#7

Actually, I wasn’t that lucky. I had to switch the buttons two weeks after I bought it. And that’s a good question: Any guides how to replace a pcb? And is there specific model or type of pcb for the SE stick?


#8

Has anyone been successful in getting a replacement PCB from madcatz?


#9

If it’s a PS3, Cthulhu would work. However if it’s for 360, you will need to do a padhack on a 4716 or something similar, which have dedicated topics.


#10

Yes i have two replacement PCBs from madcatz…I just don’t have a clue how to install them and if soldering is required…blah blah


#11

I have the same dillemma as Ketchy. My SE PCB just died out and I was wondering if there were any guides or tuts on replacing the PCB. I’m going to be ordering an Assembled Cthulhu from GamingNow.


#12

ketchy, how did you go about getting the replacements? did you just tell madcatz that your fightstick stopped working and that you wanted to fix it yourself?


#13

The replacement for the Pcbs should be very easy to deal with since there is wiring harnesses attached to the Pcb. There is some red gunk located on the board for security purposes and it should be removed prior to replacing the board. Just map out each harness pulled and just reconnect them again.


#14

I sent them an e-mail, and explained my situation, and they asked if i opened it (i told them i didn’t but i had modded it :P) but they did just send me one upon request…I just supplied them a item number thats on the back of my TE (i requested one for my SE as well, since its been having the same problem)

—Thanks puppy, ima try!

I just unscrewed it and too off the attached harness thingies (they were a bitch to remove) and now there is a little wires in a straight line in the middle left. (they say B2,B3,B4,B5) and they are connected to the USB…how do i go about removing these? :\


#15

Solder sucker. It’s a braided wick that you put on the weld, apply the iron, and it acts as a sponge to absorb the solder. It’s pretty cheap for a roll.


#16

Soldering scares me for some reason :x

–So I buy the soldering iron and apply on the opposite side of the wires to set them loose? Then I take the new PCB and stick the wires in the appropriate holes and “burn” them for the wires to stick? O_O please correct me! or link me to a soldering tut :] #~~


#17

There are soldering guides posted in the Tech Talk/Intro/Rules/Essentials thread.


#18

Saw em…They still confuse me to no end…they I just want to connect that those middle wires into the new PCB that I’ve received from madcatz.


#19

i going to try to get the pcb from madcatz like ketchy did…i just removed my pcb and it didn’t look too complicated.


#20

Unsnapping the little white parts were easy, its this part that i have a problem with:

http://img209.imageshack.us/img209/850/img0481r.jpg

See the wire? I don’t think its a simple yank n snap scenario…do i get a de-solderer and melt off the opposite side? and then plug in new pcb and then use the soldering iron? halp! halp!