SF4 hud stretched vertically

I am playing with a 4:3 aspect ratio and the hud is stretched vertically; the ultra meters are more oval shaped. Is that because the hud was inherently designed for 16:9 ratio resolutions and I can’t do anything about it?

Have you set the aspect ratio in the “pc settings” part of the options menu?
Try 4:3 or automatic.
I have a 5:4 aspect screen, so they look slightly stretched out for me at native resolution, but If I change to a 4:3 ratio resolution, I get more normal looking HUD elements.