SF4 PC, notebook, x3100, custom skins, invisible hadouken

Hi all.

Target people: X3100 users (intel’s onboard video for notebooks) and I’m pretty sure some other low-end video cards may present this problem as well.
We can play the game at 60 FPS if we set everything to low/off, 640x480, no v-sync and fixed franerates.

It’s wonderfull to be able to play such a new game at 60 fps in a crappy vga like this, but theres a problem.

The problem: Missing Textures. Ryu’s fireball for example, can only be seem if we set the “model quality” to HIGH. This is really bad because if we set model quality to high we are now playing at 30~40 fps, and we know this is unplayable. But playing with invisible hadoukens is also unplayable.

The conclusion: It seems like fireballs are part of the model texture instead of being something completely independent (ryu’s fireball’s texture are tied to Ryu’s texture, and some cards can only see this “part” when the textures are set to high, more detailed)

The solution(??): Skin mods are becoming famous right now, everyone is trying to make chars look really cool and stuff, with bring me to the question: Could this be the solution to our problems? When you guys do a skin-mod, can u change the way fireballs look? Can we be able to create a character skin that makes hadoukens be visible when model quality is set to low?

Thanks in advance

I can’t run sf4 with my laptop, no vsync, fixed frame rates…3gb ram, core2duo…

I had a bnuch of graphics glitches/etc with my laptop at first, deleting everything and redownloading it from Steam resolved those issues for me. I had similar stuff like the invisible Hadouken and such. Also sometimes characters faces would just be ilke a wireframe or something, it was very strange.

My laptop is running an ATI Mobility Radeon HD3650 I think. I don’t have it with me at the moment, but I got it a year ago or so and it is an ASUS (Core2Duo, 3GB RAM).

Hm so the download from steam is different? Is it patched or anything?

You are missing texture because the card sucks I doubt a costume patch would be of any benefit.

I know the card sux.
The thing is, when model quality is set to high, the texture is there, so there’s hope.

I have the same exact problem with one of the computers. It’s got a G41 express integrated chipset. I know it sucks, I just think it’s a shame that I can play it at 60fps but no speciall effects get rendered, so basically it’s unplayable.

It’s no just hadokens, viper’s flame,etc don’t get rendered either. I updated to the latest intel drivers but had no luck. If anyone has a solution that’d be great.

Note: Nope I can’t upgrade the video card in this PC,thank you.

FallenAngel, if you set up model quality to HIGH, can u see hadoukens and viper’s flame?

Let’s try to find a pattern here, anyone with these issues that doesn’t involve an Intel card?

Yes you’re right I can see them if I set it to HIGH. But of course I get 30 ish fps.

This is sad, I’m sure I driver update would solve it.

I “can” run the game on my Macbook. It’s the cheapest one they have. 13", white, 1000$. I run it under XP of course. Straight boot, haven’t tried through any virtual machines as the game already run slow. I have everything set to low but I do see fireballs. I don’t see the backgrounds however, it’s all pitch black except the characters and life bars, etc. I honestly don’t mind the missing bg’s, and it runs 60fps. I can play at work and they keyboard isn’t as bad of a controller as you think.

I also don’t mind not seeing BGs, but not seing fireballs is a whole different problem :frowning:

I can currently play sf4 on my laptop with the current settings @ 60 fps …

full screen = on
resolution = 640x480
v sync = off
display frame rate = on
frame rate = fixed
character models = medium
background = high
all other settings are on the first setting above base setting (so if the lowest is off, set it to low… while if the lowest setting is low set it to medium/high)

I have a amd 2.33 ghz turion dual core with 4gb ram and ati radeon 256mb graphics card (i think it’s 3100 or something … not sure as i don’t have my laptop with me right now). I’m running windows vista (64 bit) and have had no problems with it …

When i run the preformance test i get an A rank. Just keep playing with the settings and find out what works for you. Also a big help for me on my laptop is to d/c wifi. kill unnecessary services and change the priority of the sf4 process to HIGH (realtime causes it to crash sometimes). What i don’t understand is why during the preformance test it shows that it only ever uses about 150ish mb of my vram, yet if i ever try to set the resolution higher i get a c rank or lower (unplayable!) … even if i turn everything to off/low! Wierd because i can play it @ 60fps just fine with many settings turned up on 640 x 480 … i guess my graphics card is really shitty!


I got the steam download and the issue is still there. It may be an exclusive intel video card problem.
After a shitload of tweaks I managed to play the game at 52 FPS with model quality HIGH, but it’s still not good, I need a way to see hadoukens on model quality low :frowning:

X3100 sucks, it cannot even render HD content properly


My personal opinion is to not even bother. If you have to downgrade, ANY of the default settings, it’s not worth it.

Get a laptop with a dedicated GPU.

i have the same problem. it’s strange because why have the option to turn the model quality to low if you’re going to make fireballs invisible? they must have missed this before releasing the game obviously. maybe complaining about it on the official capcom boards will get them to release some kind of patch. it’s an oversight on their behalf. i guess you can upgrade your system and that will obviously fix your problem but if you don’t have the money then bitch like crazy on the official capcom forum.

It’s wierd because there seems to be placeholder Textures for certain FBs
Sim’s FB’s, Ultra
Rose FB’s, Super

Ryu,Ken,Akuma,Sagat Are outta of luck. Wierd.

The fault on this one is with the card/drivers, not sf4 - I run the game with all settings on low and everything’s visible fine, and no other graphics glitches either.

i made a thread about it on intel and on campcom

If you guys support it, it’ll be great, maybe we can solve the problem, I’m pretty sure a simple patch from Capcom or driver update from Intel could solve this issue:


I highly doubt old Intel integrated graphics even has shader 3.0+ support. It’s a lost cause man…this is 2009. It’s not Capcom’s problem/fault if people don’t have dedicated video cards.