Sf4 pc problem.


#1

Well im getting extremely bad screen tearing and def do not want to turn vsync on :confused: If I run sf4 in compatibility mode for any other windows (im on 8) there is no screen tearing at all. First of all, why in the world??

Secondly, thats great but in compatibility mode my stick wont work :frowning:

Any ideas as to

  1. Why compatibility mode gets rid of the awful tearing?
  2. Why my stick wont work when using said mode?

Thanks alot for any help, im going insane over this


#2

I would say update video card drivers.

Compatibility mode may call to something different in the drivers.

See if that helps. If it doesn’t try some beta drivers from nvidia.com or amd.com and see if that helps.

Let us know!


#3

Also the screen only tears in fullscreen but no windowed


#4

Disable Steam overlay, make sure frame limit is on.


#5

steam overlay is disabled, where do I find the option for frame limter


#6

In the SFIV options


#7

Im assuming you mean setting framerate to fixed, which I have. Oh well I found the vsync settings on my gpu’s control center, seems to have made a huge improvement with no input lag. Problem solved finally


#8

hehe i thought you had that disabled already. if u play with vsync enabled on other games you can just make a profile for SF4 to force disable vysnc. glad you got it working!


#9

In Windows 8 (and Windows 7 if you have aero enabled) the desktop is vsync’d, which is why windowed mode doesn’t tear.


#10

well it still seems pretty bad. Does everyone get screen tearing?


#11

normally its set to application default, so it’s controlled by the program. but you can go in to the gfx card settings and force all of that on or off, or set up profiles for each game.


#12

Did you update your graphics card drivers yet? and if that didnt work then update to beta drivers? if u need help let me know


#13

yea im on beta drivers on amd and also have a profile set up for sf4 with v sync on and tripple buffering.