SF5 Vsync lag question


#1

I’ll get lag from vsync, but if I hit alt+tab for the steam overlay to pop up and then close it, the lag goes away.

I turned off vsync and had no problems, but I would like to wonder why is opening steam overlay fixing it and if there’s a way to fix this problem I would like vsync on(no screen tearing)

I know it’s not laggy, because of my computer specs, cause I can fix it by shift+shift(steam overlay) then closing it and bam, game goes to 60 fps.

I just hate having to do that like 80% of the time I play, so I turned it off until I find a solution.

Can anyone explain why shit+tabbing fixes my problem? Is there another way to fix so I don’t have to do this?


#2

Hard to say, every PC is different. You combination of hardware and software and drivers aren’t the same as the next person.
What is your PC specs? What hardware and OS you are running and what setting your game is on.

In general Vsync adds additional processing with in turn adds some lag.
You want a faster game with no lag or dropped frames you turn off Vsync.

You can get a pretty, tear free picture or no lag and no frame drops.
It’s a performance vs appearance.

What you can do is make sure your drivers are updated, and have the game reautodetect everything. If your video card comes with opnimzation software, consider running it for your game.
You can also tried windowed mode instead of full screen with the window set to screen sized


#3

The issue is fixed when shift+tab(bringing up steam overlay) and then closing it…

It can run fine when I do that method, if I turn off vsync it’s perfectly fine…I don’t like the screen tear though.

I can even stream the game fine w/o fps drop with vsync on or off…I still have to shift+tab to fix but I hate doing it and wondering if there’s another way to fix it.

If I shift+tab and it fixes it, it shouldn’t be a hardware issue should it?


#4

Did you make sure your drivers and software up to date?

And whats your PC specs and whats your other game settings?


#5

all updated

win 10 / amd 8 core cpu / 16 gb ram / gtx 660 ti

I can stream with the same settings fine and w/o streaming it’s the same with v sync on…

If I hit shift+tab for steam overlay, and close it, it fixes the lag…idk why

If it can run the game streaming and shit tab fixes it, theres gotta be something other than my hardware


#6

What do you mean by the lag, vsync adds input lag(around 1-3 frames) meaning the delay between pressing a button and having it happen in the game, so the lag is gone after you shift+tab?
or do you mean lag as in something like frames going under 60, or the game feeling slow(also dropped frames)


#7

frames drop to 40-50 fps when vsync on

but if i bring up steam overlay (shift+tab) or alt tab and then bring the game window back up , the lags clears up

it doesn’t always lag, but if it does I do that

Also the weird thing is, it will lag in the game menu’s, but when the game starts it will put the game at 60 fps…it’s like ok we’re going to drop fps until the game starts, then we will make it go to 60 fps

then it lag when the game starts like 40% of the time and i have to shift+tab to fix it.

I dont think its a hardware issue, because I can stream the game and it works fine.

shift+tab fixes it too and makes my fps stay at 60…idk why i have to shift+tab or alt+tab and reopen the window


#8

Strange problem, if you’re using the in-game vsync maybe disable that and force it in Nvidias settings for SFV if you didn’t try that already and see if it helps.


#9

There’s no in game vsync, you would have to go to SF folder and open a file to edit it…

I just disabled it from nvidia and everything works 100%, i just get screen tears sometimes(not that noticeable) but still would like to be able to fix the problem…

I dont think it’s a hardware issue, i’ve seen lots of other ppl have his same issue and they’ll just disable vsync and say fk it…

I was hoping someone might know how to fix it


#10

I had the same issue a while back (around when Alex was let loose on SFV) with a rig running an i5 4460/16gb/GTX 670 on Win 10. Turning off global vsync in NVIDIA Control Panel resolved the sluggishness, but resulted in crazy screen tearing.

Uninstalling my GTX 670 drivers and a clean re-install (not thru Experience) solved the issue. What GPU are you running and which drivers? Current is 372.54 I believe.


#11

P.S. You can disable in-game vsync in SF4 via Settings but not 5. Kinda dumb IMO.
Anyone got the scoop as to why?


#12

Either to force PC input lag to match PS4 input lag or the option got dropped in a rush to release the game.

You decide!


#13

Based on my personal experience with SFV, I’ll take door #2 :wink:


#14

Oh that does sound like something that could fix it, Idk why I didn’t think of that.

I’ll uninstall the drivers and download the drivers from the site directly? Don’t use nvidia control panel correct?

thanks a lot!


#15

Yeah, since I play on a TV in the living room, v-sync is kinda a godsend in certain games. Globally disabling it is kind of a buzzkill, but necessary in situations like these. Obviously game-specific v-sync enabling/disabling is ideal.

Just grab your drivers from HERE. Uninstall the current driver (from the Windows control panel). Restart and run the installer you previously downloaded. It might be a nervous tick of mine, but I always check the box next to “perform a clean installation.”

Also, unless you truly need the extra stuff like 3D vision drivers or HD Audio (unless you pass audio thru HDMI like me) I suggest unchecking those items. Note that unchecking the Experience app might uninstall it (if you have it installed, just keep that box checked).


#16

It’s kinda of a split, ether you want V-sync or lag free game play, It’s still a issue even on a GTX 1080, but not as server or as common as the 4 year old GTX 660.
You got to choose one or the other.

I don’t know what much else to say (what I haven’t said before) other than a hardware upgrade. If you tried everything software wise.
I Do realize new video cards aren’t cheap.

With a AMD 8 core CPU (I am assuming AM3+ or FX chip) and 16 gb Ram (more than enough) your GTX 660 Ti is your bottleneck. And the GTX 600 series don’t support DX 12 or Vulcan.
You start soon to see games supporting one of those two APIs.

Nvidia GTX 970 are now down to the $250 price range and AMD offerings of the RX 390 or RX 480 isn’t bad ether.
Get a card with at least 4GB of Vram, 8GB would be even better.

SFV is a rushed product. You can edit ini files in the game to force certain settings but be careful, some edits can make the game worst.
Make back-ups of any files you decide to edit before you attempt anything. Putting the copy of a file in another folder, zip file or changing the extension will work for a back-up.


#17

I think Capcom’s recommended (not required) GPU is GTX 960 and up. Now that I have a GTX 1070, I eat 1080p for a midnight snack. 1070 is admittedly overkill for that res, but I came from a GTX 670 (so I don’t upgrade often)

GTX 1060 (or RX 480, if red’s your color) is a nice price-to-performance option for full 1080p though (if that’s what he’s running)

Perhaps if my suggestion doesn’t work, it is time for an upgrade, @ReDRuM911?


#18

This is what I got from PC Gamer http://www.pcgamer.com/street-fighter-5-system-requirements-announced/

Here is the minimum specs

Here is the required specs for optimum performance