SFV PS4 legacy controller compatible sticks/PCBs (see first post)

Just to make things easier, we can post what works and what doesn’t on the PS4 version. Will edit this as folks let us know what their results are.

Tested Working:

MadCatz SE (1stGen tested and brawl checked)
MadCatz TE (1st Gen, Soul Edition, TE: S, and MvC2 TE tested, pretty sure most of this line will work… just need confirm)
Hori Real Arcade Pro. 3 Premium VLX
Hori V3-SA
PDP Mortal Kombat Joystick (who knows, maybe someone is using the PCB in something else)
Qanba Q1
XBox360/PS3 eTokki Omni Rev. 3
PDP Injustice Stick
Mayflash (circa 2009)
Exar Exaprize USB Sanwa Edition
-Madcatz SFXT (pad)

Phreakmods Cerberus
Toodles MC Cthulhu
Toodles PS3 Cthulhu
Toodles ChImp (classic)
Toodles ChImp (SMD)
Toodles TE Kitty
Zero Delay USB (pending version model)
Paewang PCB (etokki Omni)

Tested NOT working:

PlayTech Pro Arcade
Qanba Q4 (some report working, others are not)
Qanba Q4RAF (some report working, others are not)
Eightarc Ivory (Qanba, non-fusion, wood version)
-iBuffalo SNES USB Gamepad
-Sony Dual Shock 3 (pad)
-Sony Six Axis (pad)

ZD Rematch (some report working, others are not)

I also believe (if I am not mistaken) Sony Dual Shock 3 and Sony Six Axis controllers do not work with legacy drivers.

I have a TE Kitty in a Xbox 360 SFxT V.S. stick that works on the PS4.

you are correct, just checked.

To all:
Would like some verification on other qanba sticks and hori… please let the community know so we can possibly save someone from making an errant purchase.

With the Sony Dual Shock 3 and Six Axis controller, I believe there being left out on the legacy drivers was Sony mandated. There was nothing Zero labs or even Capcom can do about it, no update is going to change that.

I do know that unofficial 3rd party controllers that mimic the Dual Shock 3 operations is not going to work with the legacy drivers.
So anything that didn’t already work on the PS4 versions of Skull Girls or Ultra Street Fighter IV is not going to work now with Street Fighter V.

I also going to be cautiously and recommend people not to use PS3 adapters that are intended for the PS3 and not the PS4.

the Qanba Q4 works fine.

thanks for the input

After seeing that post about the PS2 adapters I agree… unless someone wants to try it for the rest of the community.

Qanba Q1 works.

Interesting! Thanks for the input.

I have heard that the q2 and q3 do not work (and my eightarc ivory :frowning: which was my go-to stick for many years, now I have to use my B15s or others…the horror!) but it would seem that the q1 and q4 work.

Please keep posting your results though. If you have the ability to pop open your qanba stick and post a pic of the pcb that might be helpful as well.

Afaik theres a ps3/pc version and a ps3/pc/360 version of the q4, so might be usefull specifying witch one youve tested.

thanks for the clarifacation…

Which one do you have?

actually i cant find anything about a ps3 version now, so i might be mistaken. However, theres definitely 2 versions in terms of pcb, as seen in the lagtest thread. Theres a thread about it on the sfv section of the forum where people are reporting mixed results for the q4

I have the ps3/360/pc version.

That MC Cthulhu purchase still paying off.

I have to make the tests myself, but some friends are telling me that problems arise only when using two legacy arcade sticks. I’ll report on that later.

tried SFXT fightpad works
and my TE-S dual modded with dpdt won’t work on SFV and USFIV…will try to return it to stock this weekend to try again

I have a ZD Rematch encoder board that works under legacy as well. Also, I haven’t seen it mentioned elsewhere here on the boards. If you are using a PS3 legacy controller, the Dualshock that you log in with has an active microphone port, that you can use for chat. It is convenient. I like my Hori FC4, but it does’nt have a microphone port, so I will probably be rewiring my Fightstick/pad hybrid up with a ZD rematch now…

Could somebody test a inpin adapter

Didn’t work for me.

Zero Delay PCB (USB cable)
Just shows as incompatible wireless PS3 device when plugged in.

Couldn’t confirm PS2 cable -> Brook converter, as my PS2 mode never worked.
Maybe I just got a bad board?

I’m assuming the ChImp that was tested was the ChImp SMD, is that correct? I can test the ChImp Classic (non-SMD), and PS360+ v2.10 when I get home today.